Alexandre Duran

Well-Known Member
May 6, 2003
62
0
156
Rio de Janeiro - BRAZIL
Hi, when i crerate a new account i have the erros below:

Generating Account..../usr/lib/ruby/site_ruby/1.8/rubygems.rb:335: warning: parenthesize argument(s) for future version
/usr/lib/ruby/site_ruby/1.8/rubygems.rb:517: warning: parenthesize argument(s) for future version
/usr/lib/ruby/site_ruby/1.8/rubygems.rb:32:in `require': /usr/lib/ruby/site_ruby/1.8/rubygems/deprecate.rb:54: syntax error (SyntaxError)
define_method name do |*args, &block| # TODO: really works on 1.8.7?
^
/usr/lib/ruby/site_ruby/1.8/rubygems/deprecate.rb:55: syntax error
/usr/lib/ruby/site_ruby/1.8/rubygems/deprecate.rb:64: syntax error
/usr/lib/ruby/site_ruby/1.8/rubygems/deprecate.rb:69: syntax error from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:32
from /usr/bin/gem:17:in `require'
from /usr/bin/gem:17
Any fix ?
 

arunsv84

Well-Known Member
Oct 20, 2008
373
1
68
127.0.0.1
cPanel Access Level
Root Administrator
Do you really need Ruby for this new account? If no disable it and try to create new account.

It you need ruby, this error sound like some old version. Try to uninstall and reinstall the latest version of ruby or better submit a ticket to cPanel support at https://tickets.cpanel.net/review/login.cgi .

Cheers!!!