The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roundcube enable_spellcheck turns off on update

Discussion in 'E-mail Discussions' started by Serra, Oct 8, 2012.

  1. Serra

    Serra Well-Known Member

    Joined:
    Oct 27, 2005
    Messages:
    213
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Florida
    I'm having a major issue. Each time Roundcube is updated it turns off the spell check setting and I have an irate customer who calls and complains. (and rightly so, it should stay on). I say its a major issue because I'm sick of setting it to "TRUE" every couple of days and I'm sick of getting yelled at for it being off.

    Where can I perminately set the setting enable_spellcheck in main.inc.php to TRUE where it will not be messed up by updates?
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You cannot permanently set the file to not be updated on Roundcube updates. Instead, a /scripts/postupcp script could be created that has a backup copy of the existing configuration file (possibly in /root/main.inc.php.bak) that is copied back to the Roundcube directory. This way the changes are copied back at the end of any upcp that occurs. Roundcube wouldn't update outside upcp unless someone directly issued the command on the system to force an update.
     
  3. Serra

    Serra Well-Known Member

    Joined:
    Oct 27, 2005
    Messages:
    213
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Florida
    I'll have to do that. I really can't have the spell checker turning off each time it updates.
     
Loading...

Share This Page