The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roundcube hangs while sending mail (connection to socket timed out)

Discussion in 'E-mail Discussions' started by gegervision, Oct 27, 2009.

  1. gegervision

    gegervision Active Member

    Joined:
    Aug 10, 2002
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    I'm having the same issue. The fix editing the roundcube config did not work for me.
     
  2. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Please check for possible logged error detail from RoundCube; the following post details how to do this (using root SSH access while attempting to send in RoundCube):
    http://forums.cpanel.net/579929-post5.html

    It might be a known issue with an available fix, such as what is detailed in the following post (with example log detail for comparison):
    http://forums.cpanel.net/580101-post7.html

    If the problem is still persistent, please let us know the log detail seen via SSH.
     
  3. gegervision

    gegervision Active Member

    Joined:
    Aug 10, 2002
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    it may be a CSF issue. I did the following after looking up my error:

    http://forums.cpanel.net/f43/roundcube-not-sending-mails-105797.html

    But then I got this error in RoundCude Log:

    [27-Oct-2009 19:39:33] Invalid response code received from server (550):
    [27-Oct-2009 19:39:33 -0400] SMTP Error: SMTP error: Failed to add recipient 'xxxxxxxxxx@yahoo.com' in /usr/local/cpanel/base/3rdparty/roundcube/program/steps/mail/func.inc on line 1248 (POST /3rdparty/roundcube/index.php?_task=mail&_action=send)
     
  4. gegervision

    gegervision Active Member

    Joined:
    Aug 10, 2002
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Here is my log results (not the same as mentioned in one of the link you provided below):

    [27-Oct-2009 19:34:11] Connection timed out (110):
    [27-Oct-2009 19:34:11] Failed to connect socket: Connection timed out ():
    [27-Oct-2009 19:34:11 -0400] SMTP Error: SMTP error: Connection failed: Failed to connect socket: Connection timed out in /usr/local/cpanel/base/3rdparty/roundcube/program/steps/mail/func.inc on line 1248 (POST /3rdparty/roundcube/index.php?_task=mail&_action=send)

     
  5. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Are other webmail clients allowing to send without error, such as via Horde and SquirrelMail?

    Is there a hardware or software firewall in-use; in particular a software firewall running on the same system might be interfering. An example of software firewalls might include an iptables-wrapper, like APF, CSF/LFD, or similar third-party scripts or custom iptables configurations.
     
  6. gegervision

    gegervision Active Member

    Joined:
    Aug 10, 2002
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Yes CSF is running as I stated above. Was working fine until a few days ago.

    Can I still run
    Code:
    # /scripts/autorepair net_smtp_fix
    safely without causing any further issues.

     
  7. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    I apologize as I missed your earlier message indicating CSF was in-use.

    The autorepair script for "net_smtp_fix" should still be safe to run without causing further difficulty; to help reduce the number of variables I would try just one possible fix at a time where the issue is re-verified after attempting each corrective measure.

    For CSF, please check the following configuration options:
    SMTP_BLOCK
    SMTP_ALLOWLOCAL
    SMTP_PORTS

    Specific to CSF, the following command (via root SSH access) may be used to view the current setting of the above options:
    Code:
    # grep -i "^SMTP_" /etc/csf/csf.conf
    If using "SMTP_BLOCK" please ensure that "SMTP_ALLOWLOCAL" is enabled.

    If that alone does not fix it, please try temporarily disabling CSF to further test RoundCube.
     
  8. gegervision

    gegervision Active Member

    Joined:
    Aug 10, 2002
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Same issue with all web mail scripts. I only had RoundCube enabled so I had to add the other in tweak setting to test.

    My CSF/LFD has the following:

    SMTP_BLOCK = 1 Default: 0
    # If SMTP_BLOCK is enabled but you want to allow local connections to port 25
    # on the server (e.g. for webmail or web scripts) then enable this option to
    # allow outgoing SMTP connections to 127.0.0.1
    SMTP_ALLOWLOCAL = 1 Default: 0

    But i still get the errors
     
  9. gegervision

    gegervision Active Member

    Joined:
    Aug 10, 2002
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    I got it working. Let me follow back what I did and will post what I did to resolve it. Thx for you help and quick responses.
     
Loading...

Share This Page