Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

RoundCube Log In - too many clicks

Discussion in 'E-mail Discussion' started by mealto, Aug 16, 2009.

  1. mealto

    mealto Well-Known Member

    Joined:
    Oct 20, 2006
    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    166
    Is there a way to setup RoundCube within cPanel or WHM so that a user can log in to 1 page without having to click on the RoundCube link after passing credentials to the popup? Trying to make it easier to use RoundCube.
     
  2. logicsupport

    logicsupport Well-Known Member

    Joined:
    Jun 5, 2007
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    166
    When users are logged in directly to the webmail client like roundcube you will be denying your webmail users the functionalities like change password , Forwarding options etc ( though it can be done through cpanel )


    You can configure your server to use cookie-based authentication . You can do so by going to WHM -> Server Configuration -> Tweak Settings and select the following setting:

    Disable Http Authentication for cPanel/WebMail/WHM Logins (forces cookie authentication)
    When this is done the pop-up window will not appear which makes it easier

    Now getting into your actual issue ,
    How to login to roundcube directly ?

    1) Login in to your cPanel interface.
    2) Create subdomain, i.e webmail.domain.com ( domain.com is your actual domain name)

    Your subdomain folder path should be public_html/webmail

    3) Create .htaccess file in the document root of subdomain "public_html/webmail"

    which should contain

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^webmail.domain.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www.webmail.domain.com$
    RewriteRule ^(.*)$ http://domain.com:2095/3rdparty/roundcube/$1 [R=301,L]

    Replace domain.com with your actual domain name .

    Now when you access webmail.domain.com it should redirect you to the roundcube page . domain.come/webmail should be working as before .

    If you wish to change it for all users ( I don't recommend this as it denies the funtions I explained before) there are some ways to edit webmail custom pages which cpaneldave has explained some time before .


     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice