The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roundcube Webmail 0.8.1 Issue

Discussion in 'E-mail Discussions' started by Serra, Sep 26, 2012.

  1. Serra

    Serra Well-Known Member

    Joined:
    Oct 27, 2005
    Messages:
    213
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Florida
    I'm having an issue with Roundcube Webmail 0.8.1. Last nigh my servers updated with Roundcube Webmail 0.8.1 and it looks very cool.

    However, there is a MAJOR issue with IE. When a user goes to read mail, if a program is in the background behind the web browser, as the user clicks on the email to read it, Roundcube jumps behind the existing program (Hides itself).

    In order to read mail, the user must minimize all programs behind the browser before reading mail. This appears to be an IE issue. Firefox and Chrome work fine.

    I've had this reported by a group of users and I can reproduce this myself.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Roundcube is only available in EDGE tier right now. EDGE should really not be used in a production environment. You might want to open a ticket to cPanel Support about this so they can come by for a closer look.

    http://go.cpanel.net/bugs
     
  3. Serra

    Serra Well-Known Member

    Joined:
    Oct 27, 2005
    Messages:
    213
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Florida
    Wow, I feel totally special then since I'm running CURRENT on both my servers and I got the roundcube update to 0.8.1. Neat.

    Anyway, it has to do with the blur functionality.

    I was able to patch it and avoid the issue.

    Code:
    cd /usr/local/cpanel/base/3rdparty/roundcube/program/js
    cp list.js list.bak
    sed -i 's/$(document.activeElement).blur();/ if(document.activeElement) { if(document.activeElement.nodeName.toLowerCase() != "body") { document.activeElement.blur(); } } else { $("*:focus", window).blur(); } /g' list.js
    
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    My apologies. I did not check the changelog to see that it came out 9 days ago to CURRENT.

    Thank you for posting back a fix you found. :)
     
  5. Serra

    Serra Well-Known Member

    Joined:
    Oct 27, 2005
    Messages:
    213
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Florida
    No problem. :)

    Any, this problem is very ugly because users can't describe the problem. Since the browser acts very strange, when it blurs it drops behind whatever is on the screen. My first customer told me that every time she clicked on a mail, "Yahoo" came up!

    When I loaded up IE and tried it, I really did do a double take because my web editor appeared for no apparent reason.

    The fix appears to have worked on both my servers, so I'm good. Others seem to have had this problem going way back in Roundcube, so its only new to use cPanel users.

    Again, only in IE and only when another window is behind IE. (I'm using IE 9)
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I've opened an internal case (61383) on this and linked to this thread so that the Developers can try and duplicate.


    Thanks again.
     
Loading...

Share This Page