Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

RPM Dependency Errors

Discussion in 'General Discussion' started by sqsisa, Aug 7, 2003.

  1. sqsisa

    sqsisa Well-Known Member

    Joined:
    Apr 8, 2003
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Bay Area, CA
    Ok after running up2date -u, I now get these errors when upcp runs. up2date built dependencies for these but they are not not installed. How can remove the dependencies? :confused:

    Any help would be greatly appreciated. Thanks!

    error: package redhat-config-httpd is not installed
    error: Failed dependencies:
    httpd-mmn = 20020628 is needed by (installed) mod_python-3.0.0-10
    httpd-mmn = 20020628 is needed by (installed) mod_ssl-2.0.40-11.5
    httpd-mmn = 20020628 is needed by (installed) php-4.2.2-8.0.8
    httpd >= 2.0.40 is needed by (installed) mod_python-3.0.0-10
    httpd is needed by (installed) mod_ssl-2.0.40-11.5

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. sqsisa

    sqsisa Well-Known Member

    Joined:
    Apr 8, 2003
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Bay Area, CA
    Bump. :)

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sqsisa

    sqsisa Well-Known Member

    Joined:
    Apr 8, 2003
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Bay Area, CA
    Bump Help?;)

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,480
    Likes Received:
    30
    Trophy Points:
    158
    cPanel Access Level:
    DataCenter Provider
    Try running /scripts/updatenow then upcp to see if it still happens

    cPanel.net Support Ticket Number:
     
  5. sqsisa

    sqsisa Well-Known Member

    Joined:
    Apr 8, 2003
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Bay Area, CA
    Thanks Nick! :D

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. wwwhosts

    wwwhosts Well-Known Member

    Joined:
    Apr 25, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    NZ
    packages

    I have run /scripts/rpmup so I'm hoping all relevent cpanel packages are up to date.

    is it safe to remove the installed packages that up2date wants to update?

    i.e. httpd 2.4.0, php 4.2.2, mysql 3.2.3

    they clearly aren't used by cpanel but some of the files of httpd seem to be part of cpanels apache as well. will removing the package break apache 1.3.28?
    or any of php & mysql respectively?

    there seem to be a lot of packages installed that aren't necessary, is there a complete list of what is or isn't required for a cpanel server?

    I get this too

    Unresolvable chain of dependencies:
    MySQL-devel 4.0.13-0 requires MySQL-client

    do I need mysql-devel (delete it?) or should mysql-client be installed?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #6 wwwhosts, Aug 14, 2003
    Last edited: Aug 14, 2003
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice