The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPM Errors

Discussion in 'General Discussion' started by Belaird, Jul 31, 2006.

  1. Belaird

    Belaird Well-Known Member

    Joined:
    Jun 24, 2004
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    I've been getting various RPM errors when UPCP runs, and I am not sure how to fix it, they all seem to be related.

    Upcp parts are below:

    Code:
    courier-imap-4.0.4 is up to date
    Install Complete
    portsentry is up to date (Fri May  9 11:11:04 2003)
    RPM error.  The message was:
    Could not determine what version of Red Hat Linux you are running.
    If you get this error, try running 
    
    		rpm --rebuilddb
    
    
    RPM error.  The message was:
    Could not determine what version of Red Hat Linux you are running.
    If you get this error, try running 
    
    		rpm --rebuilddb
    
    ...........then later
    
    Creating new 'Build' script for 'PathTools' version '3.19'
    CPAN: YAML loaded ok
    ppport.h -> lib/ppport.h
    lib/File/Spec/OS2.pm -> blib/lib/File/Spec/OS2.pm
    lib/File/Spec/Mac.pm -> blib/lib/File/Spec/Mac.pm
    lib/File/Spec/VMS.pm -> blib/lib/File/Spec/VMS.pm
    lib/File/Spec/Functions.pm -> blib/lib/File/Spec/Functions.pm
    lib/File/Spec/Epoc.pm -> blib/lib/File/Spec/Epoc.pm
    lib/File/Spec/Cygwin.pm -> blib/lib/File/Spec/Cygwin.pm
    lib/File/Spec.pm -> blib/lib/File/Spec.pm
    Cwd.pm -> blib/lib/Cwd.pm
    lib/File/Spec/Unix.pm -> blib/lib/File/Spec/Unix.pm
    lib/File/Spec/Win32.pm -> blib/lib/File/Spec/Win32.pm
    Cwd.xs -> lib/Cwd.xs
    lib/Cwd.xs -> lib/Cwd.c
    /usr/bin/perl -I/usr/lib/perl5/5.8.7/i686-linux -I/usr/lib/perl5/5.8.7 /usr/lib/perl5/5.8.7/ExtUtils/xsubpp -noprototypes -typemap /usr/lib/perl5/5.8.7/ExtUtils/typemap lib/Cwd.xs
    Module::Build is not configured with C_support at /usr/lib/perl5/site_perl/5.8.7/Module/Build/Base.pm line 3731.
      ./Build  -- NOT OK
    Running Build install
      make had returned bad status, install seems impossible
    
    .............
    
    
    Checking prerequisites...
     * Optional prerequisite ExtUtils::ParseXS is not installed
     * version (0.59) is installed, but we prefer to have 0.661
     * Optional prerequisite Pod::Readme is not installed
     * Optional prerequisite ExtUtils::CBuilder is not installed
    
    ERRORS/WARNINGS FOUND IN PREREQUISITES.  You may wish to install the versions
    of the modules indicated above before proceeding with this installation
    
    Checking features:
      manpage_support....enabled
      YAML_support.......enabled
      C_support..........disabled
        - ExtUtils::CBuilder is not installed
        * Optional prerequisite ExtUtils::ParseXS is not installed
      HTML_support.......enabled
    
    ............
    
    Creating new 'Build' script for 'version' version '0.661'
    Can't locate object method "up_to_date" via package "version::Builder" (perhaps you forgot to load "version::Builder"?) at ./Build line 45.
      ./Build  -- NOT OK
    
    Almost looks like wants version .661 and I have a partial 5.8.7

    Any help wtih clean this up would be appreciated.
     
  2. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
Loading...

Share This Page