The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPM List in WHM has Vanished?

Discussion in 'General Discussion' started by topgunmike, Feb 3, 2009.

  1. topgunmike

    topgunmike Active Member

    Joined:
    Jun 8, 2008
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    N.O. La.
    Hi,
    I have a virtual dedicated server, With unlimited Whm/Cpanel
    [[ cPanel 11.24.4-R33609 - WHM 11.24.2 - X 3.9
    FEDORA 7 i686 on virtuozzo
    ]]
    {pd monthly through host},
    Everything is doing great with just a couple of bumps, but I can't seem to get my WHM RPM list to show any rpm's.

    It's been months since I checked or went to install a RPM, since before my host {GoDaddy} Upgraded our servers.

    I have tried the Rebuild Rpm DB, did not resolve,
    Also checked /var/lib/rpm/ and see

    ./ Dirnames - Name - Pubkeys - Sigmd5 - __db.003
    ../ Filemd5s - Packages - Requirename - Triggername
    Basenames - Group - Providename - Requireversion __db.001
    Conflictname - Installtid -Provideversion - Sha1header - __db.002


    Can some one Please advise me how to get WHM - RPM List to work?
    or post me a link to any info on this issue.
    Thanx,
    Mike
     
  2. topgunmike

    topgunmike Active Member

    Joined:
    Jun 8, 2008
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    N.O. La.
    comon you guys, I'm just looking for guidance, must it be like pulling teeth?

    we pay for cpanel{10.00 monthly through Godaddy}, could we get some guidance without wasting the time at ticket center, which my tickets (2) never got resolved anyway, one actualy vanished.

    if cpanel can't help, does any other users have suggestions??

    thanx,
    Mike.
     
  3. cPanelStephen

    cPanelStephen Active Member
    Staff Member

    Joined:
    Aug 7, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    This is usually indicative of issues with your system's package manager. What is the output from `yum -d 0 list`?
     
  4. topgunmike

    topgunmike Active Member

    Joined:
    Jun 8, 2008
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    N.O. La.
    ]# yum -d 0 list
    Repository base is listed more than once in the configuration
    http://apt.sw.be/redhat/el7/en/i386/dag/repodata/repomd.xml: [Errno 14] HTTP Err or 404: Not Found
    Trying other mirror.
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: dag. Ple ase verify its path and try again

    /////////////:eek:
    this don't look good?
     
  5. topgunmike

    topgunmike Active Member

    Joined:
    Jun 8, 2008
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    N.O. La.
    well, no one at cpanel has offered any resolution, or even a non official response, I NEVER got ANY response on why my RPM list won't show in WHM, since I do have RPM Folder, and have added the RPM-FORGE to the system, now when i run yum -d 0 list , I get;

    there are like 1000 of these, i don't know how to copy, and don't think i should put that much in one post, HOW do I get these to show in WHM RPM List??

    my comments at;
    http://www.trafficgetr.com/index.php?topic=15.0

    xorg-x11-drv-i810-devel.i386 2.0.0-4.fc7 updates-released
    xorg-x11-drv-ivtv.i386 1.0.1-2.fc7 updates-released
    xorg-x11-drv-jamstudio.i386 1.1.0-2.fc7 base
    xorg-x11-xbitmaps.i386 1.0.1-4.1 base
    xorg-x11-xdm.i386 1:1.1.3-1.fc7 base
    xorg-x11-xfs-utils.i386 1:1.0.5-1.fc7 updates-released
    xorg-x11-xfwp.i386 1.0.1-4.fc7 base
    xorg-x11-xinit.i386 1.0.2-22.fc7 updates-released
    xorg-x11-xkb-utils.i386 1.0.2-3.fc7 base
    xorg-x11-xsm.i386 1.0.2-5.fc7 base
    xorg-x11-xtrans-devel.i386 1.0.3-2.1.fc7 updates-released
    xorriso.i386 None:0.3.2.pl01-1.el2. rpmforge
    xosd.i386 2.2.14-9.fc7 base
    xosd-devel.i386 2.2.14-9.fc7 base
    xosview.i386 None:1.8.0-1.0.el2.dag rpmforge
    xournal.i386 0.3.3-5.fc7 updates-released
    xpa.i386 2.1.8-3.fc7 updates-released
    xpa-devel.i386 2.1.8-3.fc7 updates-released
    xpa-libs.i386 2.1.8-3.fc7 updates-released
    xpa-tcl.i386 2.1.8-3.fc7 updates-released
    xparam.i386 None:1.22-1.0.el2.rf rpmforge
    xparam-devel.i386 None:1.22-1.0.el2.rf rpmforge
    xpdf.i386 1:3.02-4.fc7 updates-released
    xpenguins.i386 None:2.2-0.2.el2.rf rpmforge
    xprobe2.i386 0.3-8.fc7 base
    xqilla.i386 2.0.0-1.fc7 updates-released
    xqilla-devel.i386 2.0.0-1.fc7 updates-released
    xqilla10.i386 1.0.2-2.fc7 updates-released
    xqilla10-devel.i386 1.0.2-2.fc7 updates-released
    xrdp.i386 None:0.4.0-1.el2.rf rpmforge
    xrestop.i386 0.4-1.fc7 base
    xrick.i386 None:0.0.021212-2.el2. rpmforge
    xsane.i386 0.994-3.fc7 base
    xsane-gimp.i386 0.994-3.fc7 base
    xsc.i386 1.5-2.fc7 updates-released
    xscorch.i386 0.2.0-10.fc7 updates-released
    xscreensaver.i386 1:5.05-3.fc7 updates-released
    xscreensaver-base.i386 1:5.05-3.fc7 updates-released
    xscreensaver-extras.i386 1:5.05-3.fc7 updates-released
    xscreensaver-extras-gss.i386 1:5.05-3.fc7 updates-released
    xscreensaver-gl-base.i386 1:5.05-3.fc7 updates-released
    xscreensaver-gl-extras.i386 1:5.05-3.fc7 updates-released
    xscreensaver-gl-extras-gss.i386 1:5.05-3.fc7 updates-released
    xsettings-kde.i386 0.6-3.fc7 updates-released
    xsp.i386 1.2.1-1.fc7 base
    xsp-devel.i386 1.2.1-1.fc7 base
    xsri.i386 1:2.1.0-10.fc6 base
    xsupplicant.i386 1.2.8-4.fc7.4 updates-released
    xsupplicant-devel.i386 1.2.8-4.fc7.4 updates-released
    yum-aliases.noarch 1.1.11-1.fc7 updates-released
    yum-allowdowngrade.noarch 1.1.11-1.fc7 updates-released
    yum-arch.noarch 2.2.2-2.fc7 base
    yum-basearchonly.noarch 1.1.11-1.fc7 updates-released
    yum-changelog.noarch 1.1.11-1.fc7 updates-released
    yum-cron.noarch 0.8.2-1.fc7 updates-released
    yum-downloadonly.noarch 1.1.11-1.fc7 updates-released
    yum-fastestmirror.noarch 1.1.11-1.fc7 updates-released
    yum-fedorakmod.noarch 1.1.11-1.fc7 updates-released
    yum-kernel-module.noarch 1.1.11-1.fc7 updates-released
    yum-list-data.noarch 1.1.11-1.fc7 updates-released
    yum-merge-conf.noarch 1.1.11-1.fc7 updates-released
    yum-presto.noarch 0.3.10-1.fc7 updates-released
    yum-priorities.noarch 1.1.11-1.fc7 updates-released
    yum-protect-packages.noarch 1.1.11-1.fc7 updates-released
    yum-protectbase.noarch 1.1.11-1.fc7 updates-released
    yum-refresh-updatesd.noarch 1.1.11-1.fc7 updates-released
    yum-security.noarch 1.1.11-1.fc7 updates-released
    yum-skip-broken.noarch 1.1.11-1.fc7 updates-released
    yum-tmprepo.noarch 1.1.11-1.fc7 updates-released
    yum-tsflags.noarch 1.1.11-1.fc7 updates-released
    yum-updateonboot.noarch 1.1.11-1.fc7 updates-released
    yum-updatesd.noarch 3.2.8-2.fc7 updates-released
    yum-upgrade-helper.noarch 1.1.11-1.fc7 updates-released
    yum-utils.noarch 1.1.11-1.fc7 updates-released
    yum-versionlock.noarch 1.1.11-1.fc7 updates-released
    yumex.noarch 2.0.4-1.fc7 updates-released
    z88dk.i386 1.8-1.fc7 updates-released
    zabbix.i386 1.4.4-1.fc7 updates-released
    zabbix-agent.i386 1.4.4-1.fc7 updates-released
    zabbix-web.i386 1.4.4-1.fc7 updates-released
    zaptel.i386 1.4.7.1-1.fc7 updates-released
    zaptel-devel.i386 1.4.7.1-1.fc7 updates-released
    zaptel-lib.i386 1.4.7.1-1.fc7 updates-released
    zaptel-utils.i386 1.4.7.1-1.fc7 updates-released
    zasx.i386 1.30-3.fc6 base
    zd1211-firmware.noarch 1.3-4.fc7 base
    zenity.i386 2.18.2-1.fc7 updates-released
    zephulor.noarch None:0.9b-1.0.el2.rf rpmforge
    zephulor-data.noarch None:0.9b-1.0.el2.rf rpmforge
    zephulor-tools.noarch None:0.9b-1.0.el2.rf rpmforge
    zeroinstall-injector.noarch 0.31-1.fc7 updates-released
    zhcon.i386 0.2.6-5.fc7 base
    zidrav.i386 1.2.0-2.fc6 base
    zile.i386 2.2.19-1.fc6 base
    zisofs-tools.i386 1.0.7-1.fc7 base
    zoneminder.i386 1.22.3-8.fc7 updates-released
    zoo.i386 None:2.10-2.0.el2.rf rpmforge
    zsh.i386 4.2.6-6.fc7 base
    zsh-html.i386 4.2.6-6.fc7 base
    zsplit.i386 None:1.2.0-1.2.el2.rf rpmforge
    zssh.i386 None:1.5-0.c.0.el2.rf rpmforge
    zsync.i386 None:0.5-1.el2.rf rpmforge
    zvbi.i386 0.2.30-1.fc7 updates-released
    zvbi-devel.i386 0.2.30-1.fc7 updates-released
    zvbi-fonts.i386 0.2.30-1.fc7 updates-released
    zynaddsubfx.i386 2.2.1-14.fc7 base
    zziplib.i386 0.13.49-1.fc7 base
    zziplib-devel.i386 0.13.49-1.fc7 base
    zziplib-utils.i386 0.13.49-1.fc7 base
    zzuf.i386 0.8.1-1.fc7 base


    my comments at;
    http://www.trafficgetr.com/index.php?topic=15.0
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I recommend you submit a support ticket if you desire a swift/official response: http://tickets.cPanel.net/submit
     
  7. Legin76

    Legin76 Well-Known Member

    Joined:
    Dec 11, 2007
    Messages:
    151
    Likes Received:
    1
    Trophy Points:
    18
    I'm getting this exact same problem on 2 servers

    cPanel 11.24.4-S33345 - WHM 11.24.2 - X 3.9 REDHAT Enterprise 5.1 i686 on standard

    and

    cPanel 11.24.4-S33345 - WHM 11.24.2 - X 3.9 REDHAT Enterprise 5.2 i686 on standard

    I've even upgraded one to the latest the current version but that has made no difference. Both servers are dedicated servers from The Planet.


    yum -d 0 list gives the following

    There was a problem importing one of the Python modules
    required to run yum. The error leading to this problem was:

    No module named storagefactory

    Please install a package which provides this module, or
    verify that the module is installed correctly.

    It's possible that the above module doesn't match the
    current version of Python, which is:
    2.4.3 (#1, Dec 11 2006, 11:38:52)
    [GCC 4.1.1 20061130 (Red Hat 4.1.1-43)]

    If you cannot solve this problem yourself, please go to
    the yum faq at:
    http://wiki.linux.duke.edu/YumFaq
     
  8. Legin76

    Legin76 Well-Known Member

    Joined:
    Dec 11, 2007
    Messages:
    151
    Likes Received:
    1
    Trophy Points:
    18
    Both servers were purchased at the same time although are slightly different spec.

    The second server shows the following when running yum

    yum -d 0 list
    rpmdb: Lock table is out of available locker entries
    rpmdb: Unknown locker ID: d5b3
    error: db4 error(22) from db->close: Invalid argument
    error: cannot open Packages index using db3 - Cannot allocate memory (12)
    error: cannot open Packages database in /var/lib/rpm
    Traceback (most recent call last):
    File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
    File "/usr/share/yum-cli/yummain.py", line 85, in main
    base.getOptionsConfig(args)
    File "/usr/share/yum-cli/cli.py", line 163, in getOptionsConfig
    disabled_plugins=self.optparser._splitArg(opts.disableplugins))
    File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 164, in _getConfig
    self._conf = config.readMainConfig(startupconf)
    File "/usr/lib/python2.4/site-packages/yum/config.py", line 685, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
    File "/usr/lib/python2.4/site-packages/yum/config.py", line 755, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
    TypeError: rpmdb open failed
     
  9. EJeanmaire

    EJeanmaire Member

    Joined:
    Mar 26, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I always had trouble getting my RPM list to populate in WHM with godaddy VPS... good luck to you, or perhaps its time to move away from Godaddy?
     
Loading...

Share This Page