The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RPM (PHP) wants to DL httpd!?!? It did... and crashed apache. Stop it?

Discussion in 'EasyApache' started by DudeBro, Apr 9, 2004.

  1. DudeBro

    DudeBro Well-Known Member

    Joined:
    Jan 30, 2004
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    Hello, I wanted to download a newer version of PHP (which didn't turn out to be as intended) from the RPM install list. I selected that, and it said adding HTTPD as a dependency. Why? I already have HTTPD... Why does it add that? Anyways... it downloaded HTTPD and crashed apache. What's up? How do I fix this thing?
     
  2. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    You must install Apache and its modules (including PHP) from source. In a Cpanel box, run /scripts/easyapache to build them. i guess you need to uninstall the httpd and php RPMs first but keep a backup copy of your configuration files just in case.
     
Loading...

Share This Page