SOLVED rpmup exits with error code 1

Operating System & Version
CentOS 7
Dec 26, 2021
cPanel Access Level
Root Administrator
I'm having an issue with server updates when /usr/local/cpanel/scripts/rpmup runs daily.
It reports the following error XID h3earn, but I'm finding it hard to get more details on this.
Which logs should I look at to rectify this problem? Has anyone had this before?

checkyum version 22.3  (excludes: bind-chroot kernel)
Loaded plugins: fastestmirror, getpagespeed, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4:
 * cpanel-addons-production-feed:
 * cpanel-plugins:
 * base:
 * epel:
 * extras:
 * updates:
Resolving Dependencies
--> Running transaction check
---> Package epel-release.noarch 0:7-14 will be updated
---> Package epel-release.noarch 1:7-14 will be an update
---> Package geoipupdate.x86_64 0:2.5.0-1.el7 will be updated
---> Package geoipupdate.x86_64 0:3.1.1-4.el7 will be an update
---> Package perl-Module-Runtime.noarch 0:0.013-4.el7 will be updated
---> Package perl-Module-Runtime.noarch 0:0.016-1.el7 will be an update
---> Package perl-Scalar-List-Utils.x86_64 0:1.27-248.el7 will be updated
---> Package perl-Scalar-List-Utils.x86_64 0:1.50-1.el7 will be an update
---> Package perl-Test-Simple.noarch 0:0.98-243.el7 will be updated
---> Package perl-Test-Simple.noarch 0:1.302164-1.el7 will be an update
---> Package popt.x86_64 0:1.13-16.el7 will be updated
---> Package popt.x86_64 0:1.16-14.el7 will be an update
--> Finished Dependency Resolution
Some packages in your transaction are brought to you by GetPageSpeed:
 - perl-Scalar-List-Utils-1.50-1.el7.x86_64
 - geoipupdate-3.1.1-4.el7.x86_64
 - perl-Test-Simple-1.302164-1.el7.noarch
 - popt-1.16-14.el7.x86_64
To enable package installs, subscribe using the following link:
(XID h3earn) “/usr/bin/yum” reported error code “1” when it ended:
checkyum version 22.3  (excludes: bind-chroot)
Dec 26, 2021
cPanel Access Level
Root Administrator
Alright, solved it eventually! Ha
The problem was that it was trying to update packages from the GetPageSpeed repositories.
This repository apparently wants you register and pay to download packages.

I disabled these repos in the getpagespeed-extras.repo file and the error disappeared.
  • Like
Reactions: cPanelAnthony