The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rrdtool want install ?

Discussion in 'General Discussion' started by Born2Kill, Sep 29, 2005.

  1. Born2Kill

    Born2Kill Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    localhost or dev/null
    test -r perl-piped/Makefile.PL.in \
    || ln -s ./perl-piped/Makefile.PL.in perl-piped/Makefile.PL.in
    test -r perl-piped/RRDp.pm \
    || ln -s ./perl-piped/RRDp.pm perl-piped/RRDp.pm
    cd perl-piped && make
    make[2]: Entering directory `/usr/local/cpanel/src/3rdparty/gpl/rrdtool-1.0.48/perl-piped'
    Manifying blib/man3/RRDp.3
    make[2]: Leaving directory `/usr/local/cpanel/src/3rdparty/gpl/rrdtool-1.0.48/perl-piped'
    test -r perl-shared/Makefile.PL.in \
    || ln -s ./perl-shared/Makefile.PL.in perl-shared/Makefile.PL.in
    test -r perl-shared/RRDs.pm \
    || ln -s ./perl-shared/RRDs.pm perl-shared/RRDs.pm
    test -r perl-shared/RRDs.xs \
    || ln -s ./perl-shared/RRDs.xs perl-shared/RRDs.xs
    cd perl-shared && make
    make[2]: Entering directory `/usr/local/cpanel/src/3rdparty/gpl/rrdtool-1.0.48/perl-shared'
    cc -c -I.. -I../src -I../gd1.3 -DHAVE_CONFIG_H -O2 -DVERSION=\"1.000481\" -DXS_VERSION=\"1.000481\" -fpic "-I/usr/lib/perl5/5.8.7/i686-linux/CORE" -DPERLPATCHLEVEL=8 RRDs.c
    In file included from ../src/rrd_tool.h:25,
    from RRDs.xs:13:
    ../src/config_aux.h:8:1: warning: "strchr" redefined
    In file included from /usr/include/string.h:417,
    from /usr/lib/perl5/5.8.7/i686-linux/CORE/perl.h:731,
    from RRDs.xs:6:
    /usr/include/bits/string2.h:396:1: warning: this is the location of the previous definition
    In file included from ../src/rrd_tool.h:25,
    from RRDs.xs:13:
    ../src/config_aux.h:80:2: error: #error "Can't compile without finite function"
    ../src/config_aux.h:84:2: error: #error "Can't compile without isinf function"
    make[2]: *** [RRDs.o] Error 1
    make[2]: Leaving directory `/usr/local/cpanel/src/3rdparty/gpl/rrdtool-1.0.48/perl-shared'
    make[1]: *** [perl_shared] Error 2
    make[1]: Leaving directory `/usr/local/cpanel/src/3rdparty/gpl/rrdtool-1.0.48'
    make: *** [install-recursive] Error 1
    ==> cPanel Log Daemon version 22.0
    ==> Unable to load Shared RRDTOOL support, rrdtool exec will be used (slow)
    Waiting for cppop to shutdown......Done


    Any help server is new and fresh installed cpanel ...

    This is happening when i try to restart cpanel.
    OS Is Fedora core 4
     
  2. Born2Kill

    Born2Kill Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    localhost or dev/null
    any ideas ?
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Can you paste in or attach the full build details when you run /scripts/rrdtoolinstall?

    I had problems on a client server recently with rrdtool because it was trying to use cpp as gcc-c++ wasn't installed. Installed gcc-c++ rpms and it worked fine.
     
  4. Born2Kill

    Born2Kill Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    localhost or dev/null
    It is installed

    rpm -qa | grep gcc
    gcc-gfortran-4.0.1-4.fc4
    gcc-4.0.1-4.fc4
    libgcc-4.0.1-4.fc4
    gcc-c++-4.0.1-4.fc4
     
  5. Born2Kill

    Born2Kill Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    localhost or dev/null
    here is the output
     

    Attached Files:

    • log.txt
      File size:
      22.9 KB
      Views:
      63
  6. Born2Kill

    Born2Kill Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    localhost or dev/null
    I do it i compiled rrdtool 1.2.11 from src and everything works fine....

    Thanks chirpy
     
  7. asm

    asm Registered

    Joined:
    Oct 13, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    there is a problem compiling rrdtool 1.0.48 with gcc 4.... No problems with 1.2.11
     
  8. Born2Kill

    Born2Kill Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    localhost or dev/null
    i have noticed that exim also have problems with gcc 4 ....

    I am thinking about to downgrade gcc
     
Loading...

Share This Page