The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rrdtool

Discussion in 'General Discussion' started by danneh3826, May 27, 2008.

  1. danneh3826

    danneh3826 Member

    Joined:
    Apr 5, 2008
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    is there any reason why cpanel install is using an ancient version of rrdtool? i try to run ./scripts/rrdtoolinstall to update it, but it does nothing (presumably up-to-date). however rrdtool reports a version of 1.0.48, when the latest version is in fact 1.2+. is there any reason for this? i've "borrowed" some rrd scripts i use at work, running on rrdtool 1.2.23, yet the version with cpanel complains about all these extra flags and DEF's i've got going on to produce my graphs, presumably because the ancient version doesn't support it.
    any ideas how i can update it?
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider


    EDGE & CURRENT are using 1.2 -- RELEASE will be shortly when it goes to 11.23
     
  3. dhost

    dhost Active Member

    Joined:
    Nov 29, 2002
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    I'm using cPanel 11.24.4-C34253 and it has rrdtool-1.049; also switched to Stable and Release -- all have v 1.049.

    Was there a rollback? Working on the rpm but keep getting errors so I'd rather use 1.2.23 if cpanel has upgraded. Where can I find it?

    Tried /scripts/rrdtoolinstall which has:

    #!/usr/bin/perl
    # cpanel10 - rrdtoolinstall Copyright(c) 1997-2006 cPanel, Inc.
    # All rights Reserved.
    # copyright@cpanel.net http://cpanel.net
    # This code is subject to the cPanel license. Unauthorized copying is prohibited

    use strict;
    use warnings;
    use POSIX;
    my $machine = (POSIX::uname())[4];

    my $version = '1.0.48';

    Any help would be appreciated.
     
    #3 dhost, Feb 25, 2009
    Last edited: Feb 25, 2009
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    As of CURRENT 33528, RRDTool is of version 1.3.6. If you are still on this older version of RRDTool that you mention, I recommend letting our technical analysts look into this for you: http://tickets.cPanel.net/submit
     
  5. dhost

    dhost Active Member

    Joined:
    Nov 29, 2002
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    rrdtool upgrade

    Thanks, I've got it now. Yes, cpanel was using the old version via /scripts/rrdtoolinstall. I then upgraded apache and php to see if that would make a difference and also changed cpanel trees but rrdtool still showed old version. rrdtool -v showed 1.0.48

    I can see other versions were on the server but not being called so I manually installed 1.2.23 for my purposes. Everything's working fine now. Thanks.
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The problem is with /scripts/rrdtoolinstall. /usr/local/cpanel/bin/rrdtoolinstall will install the newer version of RRDTool. I've notified the developers so the incongruity can be resolved. Thank you.
     
    #6 cPanelKenneth, Feb 27, 2009
    Last edited: Feb 27, 2009
Loading...
Similar Threads - rrdtool
  1. joomla
    Replies:
    2
    Views:
    563

Share This Page