Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

rsyslog disabled

Discussion in 'General Discussion' started by sparek-3, Jul 2, 2015.

  1. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,799
    Likes Received:
    131
    Trophy Points:
    343
    cPanel Access Level:
    Root Administrator
    Why does cPanel think rsyslog is disabled? Where is it getting this information?

    root@host [~]# /scripts/restartsrv_rsyslog
    The “rsyslog” service is disabled.
     
  2. JonathanW-GOT

    JonathanW-GOT Member
    PartnerNOC

    Joined:
    Jul 2, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Norfolk, Virginia
    cPanel Access Level:
    Root Administrator
  3. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,799
    Likes Received:
    131
    Trophy Points:
    343
    cPanel Access Level:
    Root Administrator
    It is enabled. That's why I'm perplexed at this issue.

    /etc/init.d/rsyslog restart

    restarts the service without issue.
     
  4. JonathanW-GOT

    JonathanW-GOT Member
    PartnerNOC

    Joined:
    Jul 2, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Norfolk, Virginia
    cPanel Access Level:
    Root Administrator
    Thank you for letting me know. What I would recommend is that you click save in the service manager to help reload the services. If you are still seeing this message, I would recommend that you run a "/scripts/upcp --force" command. This often helps resolve the issue at hand and let me know if you are still experiencing it after this.
     
    #4 JonathanW-GOT, Jul 2, 2015
    Last edited by a moderator: Sep 14, 2016
  5. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,799
    Likes Received:
    131
    Trophy Points:
    343
    cPanel Access Level:
    Root Administrator
    I don't really think that's the problem.

    I think it's hitting an /etc/*disabled file (although one for rsyslog does not exist there) or equivalent file some where. Something is making cPanel believe that rsyslogd is disabled. I do not know where all of these files are scattered about.
     
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,443
    Likes Received:
    1,962
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Internal case number 188961 is open to address an issue where "WHM >> Service Configuration >> Service Manager" does not properly re-enable rsyslog/rsyslogd. Feel free to our monitor our change log for this case number to see when the resolution has been released. You can start the service via the following command in the meantime:

    Code:
    /etc/init.d/rsyslog start
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice