The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rsyslogd giving error and won't start

Discussion in 'CloudLinux' started by jamiedolan, Mar 10, 2011.

  1. jamiedolan

    jamiedolan Member

    Joined:
    Jan 18, 2011
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Neenah, Wisconsin, United States
    Hello;

    I'm trying out Cpanel, and so far everything is looking great. I'm running on Centos 64bit with CloudLinux. The few little glitches I've had, I've been able to easily find answers for here in the forum.

    I just got an error when saving in the Service Manager, and I can't find anything that addresses it.

    Waiting for rsyslogd to restart...............................................................finished. rsyslogd has failed, please contact the sysadmin (result was "rsyslog is not running").

    Rsyslogd and syslogd and both enabled, and for syslogd, monitor is checked also.

    I ran /scripts/restartsrv_rsyslogd and it replied: Shut down sysklogd before you run rsyslog.

    Should I disable one of these or are they both suppose to be running, if they are both suppose to be running, can you steer me in the right direction for fixing this.

    Thank You

    Jamie
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    You cannot run two logging daemons simultaneously. You need choose which you want: syslogd, or rsyslogd. In Service Manager only enable one of the daemons (services).
     
  3. jamiedolan

    jamiedolan Member

    Joined:
    Jan 18, 2011
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Neenah, Wisconsin, United States
    Thanks very much. Looks like it's working fine now.

    Jamie
     

Share This Page