The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ruby gem installer not working.

Discussion in 'General Discussion' started by gregf, Oct 5, 2008.

  1. gregf

    gregf Member

    Joined:
    Sep 17, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Well over the last few days I got cpanel installed on freebsd 7 64bit version. Had a few issues that got resolved and this appears to be the last one.

    When you login and try to use the gem installer in cpanel the page reloads to a small green box where I'm sure the output should be but nothing ever happens.

    If you login as that user and run gem install from the command line you are presented with this.

    Code:
    $ gem install haml
    ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions into the /usr/local/lib/ruby/gems/1.8 directory.
    here's the gemrc cpanel created.

    Code:
    --- 
    gem: --remote --gen-rdoc --run-tests
    gemhome: /usr/home/lizard/ruby/gems
    gempath: 
      - /usr/local/lib/ruby/gems/1.8:/usr/home/lizard/ruby/gems
    rdoc: --inline-source --line-numbers
    Any ideas?
     
  2. gregf

    gregf Member

    Joined:
    Sep 17, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ended up tracking this down to being a bug in gemwrapper.

    Filed a bug report here
     
Loading...

Share This Page