The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ruby Gems on Centos 4.5

Discussion in 'General Discussion' started by brianc, May 23, 2007.

  1. brianc

    brianc Well-Known Member

    Joined:
    May 16, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Has anyone gotten Ruby Gems to install correctly on Centos 4.5. My exact OS is CENTOS Enterprise 4.5 x86_64.

    I have tried /scripts/installruby and the instructions listed at http://wiki.rubyonrails.com/rails/pages/HowtoInstallAndRunRubyOnRailsOnCpanel and I receive the following error message when I get to step "ruby setup.rb"

    Code:
    root@server [/usr/local/src/rubygems-0.9.3]# ruby setup.rb                       
    setup.rb:786:in `require': no such file to load -- rbconfig (LoadError)
            from setup.rb:786:in `load_rbconfig'
            from setup.rb:768:in `invoke'
            from setup.rb:1578
    It seems some other users are getting the same error message and the common factor is that it is on a Centos 4.4 or 4.5 64bit setup.

    Could someone please help me out here? Thanks!

    Brian
     
  2. brianc

    brianc Well-Known Member

    Joined:
    May 16, 2003
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    16
    Come on cpanel forums help me out here. No one has an answer for this? Has anyone had any success getting Ruby Gems to run on Centos 4.5 x64?

    Brian
     
  3. rone

    rone Well-Known Member

    Joined:
    Jan 14, 2007
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    The Netherlands
    cPanel Access Level:
    Root Administrator
    I have the same problem it lookslike it is a 64bit problem on my 32bit machine it works fine for me :(
     
Loading...

Share This Page