The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ruby issue (ruby.h not found)

Discussion in 'General Discussion' started by Voltar, Dec 15, 2008.

  1. Voltar

    Voltar Well-Known Member

    Joined:
    Apr 30, 2007
    Messages:
    269
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Bakersfield, California
    Trying to install any ruby gems seems to bring up an error about not finding ruby.h.
    Code:
    INFO:  `gem install -y` is now default and will be removed
    INFO:  use --ignore-dependencies to install only the gems you list
    Building native extensions.  This could take a while...
    ERROR:  Error installing typo:
    	ERROR: Failed to build gem native extension.
    
    /usr/bin/ruby extconf.rb install -y typo
    checking for fdatasync() in -lrt... yes
    checking for sqlite3.h... no
    
    make
    make: *** No rule to make target `ruby.h', needed by `sqlite3_api_wrap.o'.  Stop.
    
    
    Gem files will remain installed in /home/voltarus/ruby/gems/gems/sqlite3-ruby-1.2.4 for inspection.
    Results logged to /home/voltarus/ruby/gems/gems/sqlite3-ruby-1.2.4/ext/sqlite3_api/gem_make.out
    
    This is a fresh cPanel install on CentOS 5.
    Code:
    cPanel 11.24.2-C32384 - WHM 11.24.2 - X 3.9
    CENTOS 5.2 x86_64 on standard
    On my other servers, setting up Ruby with
    Code:
    /scripts/installruby
    /usr/local/cpanel/bin/ror_setup
    Has always led to a working environment. I've also tried reinstalling Ruby with the --force flag. I'm sure this is something simple but I've been up half the night setting up servers and can't think of anything right now.
     
  2. RobertF

    RobertF Member

    Joined:
    May 22, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Can you submit a ticket on this and ask for Robert?
     
  3. iwdev

    iwdev Member

    Joined:
    Mar 5, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Is submitting a ticket still the correct way to get help with this? I've just hit the same problem, also trying to install the sqlite3-ruby gem
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I recommend submitting a support ticket, as it would be the fastest way for us to diagnose this issue on your server: http://tickets.cpanel.net/submit
     
  5. salamandyr

    salamandyr Member

    Joined:
    Apr 29, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    was this ever resolved? i'm getting the same issues with headers not found, trying to install any gems via WHMs Ruby gem installer.
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    If you have the Compilers Tweak enabled, that could be interfering with the installation of Ruby Gems.
     
Loading...

Share This Page