The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ruby on Rails Application not running

Discussion in 'General Discussion' started by 51face, Feb 24, 2012.

  1. 51face

    51face Registered

    Joined:
    Feb 24, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi, I have issue with ruby on rails application.

    I tried to create new apps on ruby on rails on cpanel (installing redmine to be exact). I thought all the setting has configured well enough. When I click "run" button on the application list, it tells that it's started. this is the exact message:

    "The following Ruby on Rails application was started: redmine"

    but, as I go back to the application list, I see that app status of that application is not running. I tried this several times. I googled about it, and found this forum thread

    http://forums.cpanel.net/f42/ruby-rails-issue-118125.html

    which ended with no solution written down. There is someone (View Profile: cPanelMatt - cPanel Forums) who asked us to open support ticket here... so I did submit a support ticket to cpanel customer support asking about how can I solve my problem.

    Apparently, they didn't tell me how to solve the problem. The solved the problem themselves instead. And now I'm facing the same problem again and still no clue how to solve this.

    Anybody could help me?

    thanks anyway
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you post the ticket number so we can check the ticket to determine the specific solution that was provided to you in the past?

    Thank you.
     
  3. mozgis

    mozgis Registered

    Joined:
    Apr 4, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Same problem here is there any solution?
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    The biggest reason for Rails applications to not work is due to having the wrong Rails version:

    Code:
    rails -v
    What do you get when running that command in root SSH?
     
Loading...

Share This Page