Status
Not open for further replies.

kshazad

Member
Nov 4, 2010
21
0
51
Whenever I try to create ruby on rails applciation in cPanel, I get the following error:

PHP:
Your app is NOT installed because there was a problem. Try again or contact our support team. 

No supported version of rails found.

My current version is:
ruby 1.8.7 (2009-06-12 patchlevel 174) [i686-linux]
Rails 2.3.11

Any ideas?
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
The newest cPanel is now requiring Rails 2.3.12 rather than 2.3.11, so simply run the following command in root SSH on the machine:

Code:
gem install rails -v=2.3.12
Thanks!
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
You can have multiple versions of rails on the same machine. cPanel will pick up the latest installed version. It's really simple to have two versions and still support cPanel installing properly:

Code:
gem install rails -v=2.3.11
gem install rails -v=2.3.12
If you do that, you'll get both versions installed:

Code:
gem list --local | grep -i rails
 

iggant

Registered
Aug 15, 2011
1
0
51
Hi,
What is about if my application require rails 3.0.0.

Code:
gem list --local | grep -i rails
rails (3.0.0)
And I also receive this error:
Your app is NOT installed because there was a problem. Try again or contact our support team.

No supported version of rails found.

Please, advise something
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
As I stated in this thread:

The newest cPanel is now requiring Rails 2.3.12
cPanel will pick up the latest installed version.
You cannot have Rails 3+ on the server and have cPanel work to install Rails applications, because the latest version cPanel will support is Rails 2.3.12 and cPanel will always pick up the latest version you have installed. If it detects anything higher than 2.3.12, it will not work to install applications.

If you want to use Rails 3, you can do that, but cPanel will not work with it. The only method I know for getting applications to work under Rails 3 would be to use mod_rails + Rails 3 and to manually generate applications. I provided a how-to on doing this, which I discussed in this forum thread:

http://forums.cpanel.net/f5/installing-mod_rails-rails-3-0-9-cpanel-machine-223162.html

We have a feature request thread about how cPanel 11.34 will include Rails 3 and mod_rails at this location:

http://forums.cpanel.net/f145/mod_r...upport-case-44197-a-152577-p2.html#post854282
 

asfik

Member
Mar 31, 2006
16
3
153
Indonesia
cPanel Access Level
Root Administrator
Hello,

I have same issue with the following configuration:

WHM 11.30.3 (build 5)

$ ruby -v
ruby 1.8.7 (2009-06-08 patchlevel 173) [x86_64-linux]

$ gem -v
1.3.6

$ gem list --local | grep -i rails
rails (2.3.12, 2.3.11, 2.3.5)

cPanel error:

Your app is NOT installed because there was a problem. Try again or contact our support team.

Show Details
No supported version of rails found.

Any comments is really appreciated.

Thank you.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Try updating Rails as I believe we may have updated it again (per internal case 52362) to Rails 2.3.14:

Code:
gem install rails -v=2.3.14
 

Brian

Well-Known Member
Dec 1, 2010
117
3
68
Texas
cPanel Access Level
Root Administrator
A quick way to determine the version of Rails that your server is expecting/requiring is to run:

Code:
egrep "^my @rails.*-v=" /scripts/installruby
It will spit out something like this:
Code:
my @rails        = ( 'rails',                                     '-v=2.3.14' );
That would then imply that 2.3.14 is the latest rails version cPanel is expecting. You could then install it per Tristan's above instructions.
 

waland09

Registered
Oct 2, 2011
1
0
51
cPanel Access Level
Website Owner
Hello,

I too am having issues creating a new RoR app from cPanel (the error message being "No supported version of rails found").

I have 2.3.11, 2.3.12, and 2.3.14 installed, but "rails -v" reports "Rails 2.3.12". Could this somehow be causing an issue?

(and the egrep command up above doesn't work for me because I have no directory /scripts/installruby anywhere that I can find -- only "ruby" and "rails_apps", neither of which has a /scripts directory)

Thanks in advance for any suggestions!
 
Last edited:

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
How did you install rails 2.3.14 on the machine? I imagine you have both /usr/bin and /usr/local/bin for rails and that's why you aren't getting 2.3.14 on version check due to it being installed in the wrong location. If that's the case, you'd want to run the rails -v check on the binaries:

Code:
/usr/local/bin/rails -v
/usr/bin/rails -v
As for /scripts/installruby, that is a file rather than a directory. Also, if you do not have a /scripts directory, I'm uncertain how the machine could be running cPanel, since either that directory (/scripts) or a symlink for that directory to /usr/local/cpanel/scripts should exist on any cPanel machine.
 
Status
Not open for further replies.