The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

run a file from the cgi-bin folder

Discussion in 'General Discussion' started by tonyevans, Apr 19, 2008.

  1. tonyevans

    tonyevans Member

    Joined:
    Mar 1, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hi All, I am very new at all this so please be gentle with me.

    I am trying to put an Auction program on a site and need to run a file from the cgi-bin folder – I have set the permission as specified in the instructions but when I try to call it with www.stampopshop.com/cgi-bin/envtest3.pl as per the instructions I just get a 404 error Page not found?????

    Help Please
    Tony
     
  2. LiNUxG0d

    LiNUxG0d Well-Known Member

    Joined:
    Jun 25, 2003
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gatineau, Quebec, Canada
    Hi Tony,

    If this is a newly created domain with fresh DNS transfer done, you might be experiencing propagation. I can't duplicate the 404. I can see a page that gives you lots of environment details... no 404:

    One line on the page: /home/zimbabwe/public_html/cgi-bin/envtest3.pl

    I cannot see any issues at the present time. If you're using Windows XP, open up a command prompt by clicking on Start -> Run... and typing "cmd" and hitting OK.

    Once the prompt is up, issue this command: ipconfig /flushdns

    If you're on Vista, you will need click on the Windows Button -> Type 'cmd' in the search box and when you see the cmd executable, right-click it, "Run as Administrator..." and then issue the ipconfig /flushdns command.

    I really think this is a cache issue, not exactly a server issue as I can see everything fine. :)

    I hope this comes through as good news my friend! :)

    Let me know if you have any follow-up questions.

    Regards,
     
Loading...

Share This Page