The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Running /scripts/postupcp...Can't open /var/cpanel/3rdparty/etc/php.ini: No such file

Discussion in 'General Discussion' started by isputra, May 8, 2008.

  1. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    Hi,

    I just upgrade WHM to WHM 11.23.0 cPanel 11.23.0-C24218 and have this message at the end of proccess upcp (using /scripts/upcp) :

    Running /scripts/postupcp...Can't open /var/cpanel/3rdparty/etc/php.ini: No such file or directory.
    ...Done


    Is this normal ?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
  4. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    This is what in inside /scripts/postupcp :

    Code:
    #!/bin/sh
    perl -p -i -e 's/^.*register_globals.*=.*$/register_globals = On/g' /usr/local/cpanel/3rdparty/etc/php.ini
    perl -p -i -e 's/^.*register_globals.*=.*$/register_globals = On/g' /var/cpanel/3rdparty/etc/php.ini
    perl -p -i -e 's/^.*register_globals.*=.*$/register_globals = On/g' /usr/local/cpanel/3rdparty/etc/php.ini
    perl -p -i -e 's/^.*register_globals.*=.*$/register_globals = On/g' /var/cpanel/3rdparty/etc/php.ini
    perl -p -i -e 's/^.*register_globals.*=.*$/register_globals = On/g' /usr/local/cpanel/3rdparty/etc/php.ini
    perl -p -i -e 's/^.*register_globals.*=.*$/register_globals = On/g' /var/cpanel/3rdparty/etc/php.ini
    
     
  5. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    Anyone can help me ?

    It's look like Fantastico part like Infopro mention and i think it's added when fantastico update every day through cron.

    Fantastico also not works either.
     
  6. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    You will need to contact fantastico as it looks like a bug in their software.
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Remove just this stuff and see how it goes:

    Worse case you can't get into Fantastico.

    I just removed those lines from mine, too.
     
  8. isputra

    isputra Well-Known Member

    Joined:
    May 3, 2003
    Messages:
    576
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Mbelitar
    Remove from /scripts/postupcp and Fantastico don't works :D
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Still working here, cPanel 11.23.3-C25576
    . I do have ioncube ticked in the PHP section of tweak settings though.
     
Loading...

Share This Page