johnnybravoh

Member
Oct 2, 2003
9
0
151
Hello,

I have set up automated backups in WHM and configured an external destination to be S3. The S3 destination validates just fine. When looking at /usr/local/cpanel/logs/cpbackup_transporter/ log file I see the following:

[2016-01-11 13:41:55 -0600] info [cpbackup_transporter] Uploading system backup file /backup/2016-01-11/system_files.tar to S3
[2016-01-11 13:41:56 -0600] info [cpbackup_transporter] Upload attempt #1 starting for /backup/2016-01-11/system_files.tar to /<directory_name>/2016-01-11/system_files.tar for destination: S3
[2016-01-11 13:41:56 -0600] warn [cpbackup_transporter] Upload attempt failed: Failure in initiate_multipart_upload: Amazon::S3: Amazon responded with 307 Temporary Redirect
at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/Amazon/S3/Bucket.pm line 97.
at /usr/local/cpanel/Cpanel/LoggerAdapter.pm line 27.

From what I've seen the 307 Temporary redirect indicates that the bucket isn't available but the successful validation seems to confirm that it is. Indeed, I have confirmed that the bucket I'm using is valid.

Any ideas?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,219
463
Hello :)

If the bucket is recently created (within minutes), Amazon's services have not fully propagated the bucket information in their network. This causes a redirect output from their end, which causes the backup transporter to fail. If it's existed longer than several minutes, could you verify which region it's configured on?

Thank you.
 

johnnybravoh

Member
Oct 2, 2003
9
0
151
It's on oregon or us-west-2. When I researched this initially I had read that this could be a propagation issue, but I waited what I believed was an appropriate amount of time (>.5 hr) and it still happened. I just force ran the backup again while typing this and got the same message.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,219
463
I am happy to see the issue is now resolved. Thank you for updating us with the outcome.