The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SA3 - learn & bayes features broken?

Discussion in 'General Discussion' started by indiboi, Oct 2, 2004.

  1. indiboi

    indiboi Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    I just updated to 'Edge' to see if this problem had been solved by the 'SA 3.0' support it adds, but the problem persists. I've also tried to manually update the relevant perl modules with no success --they're already up to date, even after a cpan cache clearing.

    Sa-learn for it's normal purposes of learning spam or ham, when run, just sits there, without showing it's 'dots of progress' or any other indication that it is actually running.

    When trying to run 'sa-learn --import' I get this message:

    Can't locate object method "upgrade_old_dbm_files" via package "Mail::SpamAssassin::BayesStore::DBM" at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/CmdLearn.pm line 157.

    When trying to run 'sa-learn --sync' I get a message indicating the command doesn't exist.

    When running 'sa-learn -V' it does indeed say it's 3.0 though...

    I'm being inundated with spam that would have normally been caught with the bayesian database, so it -appears- as though that aspect is broken (not reading the old database, no way to convert the database styles), along with any way of actually teaching it one way or the other.

    Is there anyone experiencing this or know a fix?

    --update--

    I fixed it by compiling/installing the SA from the tarball and restarting exim. I don't know if this problem was specific to my server or something related to CPanel's packaging.
     
    #1 indiboi, Oct 2, 2004
    Last edited: Oct 2, 2004
  2. VCServer

    VCServer Active Member

    Joined:
    Nov 19, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    I have this Problem too on 3 CPanel Servers.
    Can anyone help? :confused:
     
  3. spiritguardian

    spiritguardian Active Member

    Joined:
    Apr 30, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Spam Assassin confused?

    Oct 8 10:35:57 neo spamd[1798]: configuration file "/usr/share/spamassassin/20_body_tests.cf" requires version 2.55 of SpamAssassin, but this is code version 3.000000. Maybe you need to use the -C switch, or remove the old config files? Skipping this file at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Conf/Parser.pm line 329.
    Oct 8 10:35:57 neo spamd[1798]: configuration file "/usr/share/spamassassin/20_compensate.cf" requires version 2.55 of SpamAssassin, but this is code version 3.000000. Maybe you need to use the -C switch, or remove the old config files? Skipping this file at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Conf/Parser.pm line 329.
    Oct 8 10:35:57 neo spamd[1798]: configuration file "/usr/share/spamassassin/20_head_tests.cf" requires version 2.55 of SpamAssassin, but this is code version 3.000000. Maybe you need to use the -C switch, or remove the old config files? Skipping this file at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Conf/Parser.pm line 329.
    Oct 8 10:35:57 neo spamd[1798]: configuration file "/usr/share/spamassassin/20_html_tests.cf" requires version 2.55 of SpamAssassin, but this is code version 3.000000. Maybe you need to use the -C switch, or remove the old config files? Skipping this file at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Conf/Parser.pm line 329.
    Oct 8 10:35:58 neo spamd[1798]: configuration file "/usr/share/spamassassin/20_meta_tests.cf" requires version 2.55 of SpamAssassin, but this is code version 3.000000. Maybe you need to use the -C switch, or remove the old config files? Skipping this file at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Conf/Parser.pm line 329.
    Oct 8 10:35:58 neo spamd[1798]: configuration file "/usr/share/spamassassin/20_phrases.cf" requires version 2.55 of SpamAssassin, but this is code version 3.000000. Maybe you need to use the -C switch, or remove the old config files? Skipping this file at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Conf/Parser.pm line 329.
    Oct 8 10:35:58 neo spamd[1798]: configuration file "/usr/share/spamassassin/20_porn.cf" requires version 2.55 of SpamAssassin, but this is code version 3.000000. Maybe you need to use the -C switch, or remove the old config files? Skipping this file at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Conf/Parser.pm line 329.
    Oct 8 10:35:58 neo spamd[1798]: configuration file "/usr/share/spamassassin/20_uri_tests.cf" requires version 2.55 of SpamAssassin, but this is code version 3.000000. Maybe you need to use the -C switch, or remove the old config files? Skipping this file at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Conf/Parser.pm line 329.
    Oct 8 10:35:58 neo spamd[1798]: configuration file "/usr/share/spamassassin/23_bayes.cf" requires version 2.55 of SpamAssassin, but this is code version 3.000000. Maybe you need to use the -C switch, or remove the old config files? Skipping this file at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Conf/Parser.pm line 329.
    Oct 8 10:36:00 neo spamd[1798]: server started on port 783 (running version 3.0.0)
    O
     
  4. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    ls -al /usr/share/spamassassin

    should list all the files on the date that your SA got updated.
    Mine got updated on 24th September, and all the files in that directory are of that date.

    The errors clearly highlight the fact that *.cf's in /usr/share/spamassassin does not seem to have been overwritten...

    Anup
     
  5. spiritguardian

    spiritguardian Active Member

    Joined:
    Apr 30, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Right. All of these .cf files are the old version. How do I get new .cf files? Many of them have "require version 2.55" in them...
     
  6. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    Suggestion:

    cd /usr/share/spamassassin
    mkdir oldrules
    cp -p *.* /usr/share/spamassassin/oldrules
    rm -f *.*

    Reinstall Mail::Spamassassin (can do it from WHM)
    restart Exim

    Check if the errors are gone
    If it does then rm -Rf /usr/share/spamassassin/oldrules

    Anup
     
  7. spiritguardian

    spiritguardian Active Member

    Joined:
    Apr 30, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I already attempted to "Install a Perl Module" from WHM but it said everything was up to date for SpamAssassin. How do I first uninstall a perl module with WHM?
     
  8. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    From shell run following commands

    perl -MCPAN -e shell
    You will get the following at prompt.

    cpan >

    From there run following command:

    force install Mail::SpamAssassin

    This will install lates SA irrespective of whether it is upto date or not.

    Anup
     
Loading...

Share This Page