The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sablotron XSLT and easyapache

Discussion in 'EasyApache' started by furtherahead, Dec 14, 2002.

  1. furtherahead

    furtherahead Member

    Joined:
    Nov 22, 2002
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Has anyone successfully used /scripts/easyapache to get Sablotron's XSLT functionality running?

    I ran easyapache, and selected Sablotron XSLT under the PHP modules, but it doesn't appear when I view phpinfo() on the server...

    I didn't see any specific error messages when I ran easyapache, and I'm not sure where errors would be logged from running easyapache...]

    Any thoughts/help?

    Derek.
     
  2. jimcarter

    jimcarter Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    152
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    it worked fine for me,
    only suggestion what I can think of is to try re-running easyapache
    thanks
     
  3. furtherahead

    furtherahead Member

    Joined:
    Nov 22, 2002
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Thanks jimcarter...

    I guess my next question is this: should I see it listed when I do a phpinfo()???

    Perhaps it is working and I just don't know it... although it is not listed when I do php -m to list the installed modules.

    I'll try again...
    Derek.
     
  4. furtherahead

    furtherahead Member

    Joined:
    Nov 22, 2002
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    OK -- tried to rerun easyapache.

    It looked much better this time, but still found errors...

    Here is what I think is relevant:

    -------------------
    checking for Sablotron libraries in the default path... configure: error: not fo
    und. Please re-install the Sablotron distribution
    make: *** No targets specified and no makefile found. Stop.
    make: *** No rule to make target `install'. Stop.
    ./configure --prefix=/usr --with-xml --enable-bcmath --enable-calendar --enable-
    ftp --with-gd=../gd-2.0.4 --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-
    xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysql --with-pear --enable-xslt
    --with-xslt-sablot --enable-sockets --enable-track-vars --enable-versioning --wi
    th-zlib
    --------------------

    does this mean I have to do something with Sablotron manually before I try to run easyapache? I've seen that others have had to manually configure certain modules because easyapache wouldn't do it for them...

    Again, any thoughts/help appreciated...
    Derek.
     
  5. jimcarter

    jimcarter Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    152
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    Im not really sure about that last part sorry, maybe someone more experienced can help you out,
    it should appear in your php info though, at the top in the configure line, and then just above the XML information, it should say:
    xslt
    XSLT support enabled
    thanks
     
  6. payne

    payne Well-Known Member

    Joined:
    May 31, 2003
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Seattle
    I really need to get this going and am having the exact same problem. I run easyapache asking for sablotron and right near the end, I get the:

    ===========================
    checking whether to enable xslt support... yes
    checking for XSLT Sablotron backend... yes
    checking for libexpat dir for Sablotron XSL support... yes
    checking for iconv dir for Sablotron XSL support... yes
    checking for JavaScript for Sablotron XSL support... yes
    checking for Sablotron libraries in the default path... found in
    configure: error: not found. Please re-install the Sablotron distribution.
    ============================

    I went back and rpm -Uvh both Sablotron-0.98-1 and js-1.5rc4-2, reran easyapache and got the same thing.

    Any help would be MUCH appreciated... and I really hope I don't have to do a manual build of php. Anyone??

    cPanel.net Support Ticket Number:
     
  7. shaun

    shaun Well-Known Member

    Joined:
    Nov 9, 2001
    Messages:
    698
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Clemente, Ca

Share This Page