The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Safe Mode!! Help??!?

Discussion in 'General Discussion' started by SimGuy, Dec 4, 2002.

  1. SimGuy

    SimGuy Registered

    Joined:
    Oct 20, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    How do I turn off safemode for a single account?

    I added php_value safe_mode 0 to the VirtualHost thing in httpd.conf and restarted apache. It dosnt work, I dont get any errors from apache starting but I still get safemode errors. I tried php_value safe_mode off too and no luck:(
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Would this work?

    &IfModule mod_php4.c&
    php_flag safe_mode off
    &/IfModule&
     
  3. moronhead

    moronhead Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    16
    [quote:cb50def84b][i:cb50def84b]Originally posted by SimGuy[/i:cb50def84b]

    How do I turn off safemode for a single account?

    I added php_value safe_mode 0 to the VirtualHost thing in httpd.conf and restarted apache. It dosnt work, I dont get any errors from apache starting but I still get safemode errors. I tried php_value safe_mode off too and no luck:([/quote:cb50def84b]
    What you needed was:

    php_admin_value safe_mode 0

    iminteractive's solution should also work for you.

    If you are disabling safe mode for a particular account you may want to restrict the user moving out of their allocated space for enhanced security by adding this in the VirtualHost:

    php_admin_value open_basedir &/home/username:/tmp&

    Regards,

    Norman
     
  4. ozzi4648

    ozzi4648 Guest

    [quote:99561a031f][i:99561a031f]Originally posted by moronhead[/i:99561a031f]

    [quote:99561a031f][i:99561a031f]Originally posted by SimGuy[/i:99561a031f]

    How do I turn off safemode for a single account?

    I added php_value safe_mode 0 to the VirtualHost thing in httpd.conf and restarted apache. It dosnt work, I dont get any errors from apache starting but I still get safemode errors. I tried php_value safe_mode off too and no luck:([/quote:99561a031f]
    What you needed was:

    php_admin_value safe_mode 0

    iminteractive's solution should also work for you.

    If you are disabling safe mode for a particular account you may want to restrict the user moving out of their allocated space for enhanced security by adding this in the VirtualHost:

    php_admin_value open_basedir &/home/username:/tmp&

    Regards,

    Norman[/quote:99561a031f]

    That doesnt work either. Where exactly did you place php_admin_value safe_mode 0? Can you give us an example. I have place it everwhere in the virtual domain and nada!

    Fatal error: Dynamically loaded extensions aren't allowed when running in SAFE MODE
     
  5. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    I would suggest making it the last two lines in the VirtualHost entry for the particular account:

    php_admin_value safe_mode 0
    php_admin_value open_basedir &/home/account_username/tmp&
    &/VirtualHost&

    You'll note that I took out the colon after 'username' as include by ozzi. I'm just guessing here as I don't understand why it is included (I've seen another example using it also) since there is a 'tmp' directory created in the account root, when the account is setup by WHM, so a valid path &should not& need it.


    Now let me ask you a question in return. Wen you got the error msg. &Fatal error&, was that after a Reboot or Apache Restart? I'm having trouble getting 'mod_perl' to install & run properly and I'm wondering if it's because I have PHP running in SafeMode -- although I don't see the connection, anything is possible and &I do want& mod_perl to run.
     
Loading...

Share This Page