The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Safe to update?

Discussion in 'General Discussion' started by fog, Oct 3, 2002.

  1. fog

    fog Well-Known Member

    Joined:
    Jun 22, 2002
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    My current server info...
    WHM 5.0.0
    Cpanel 5.0.0-28
    RedHat 7.2

    I only have the packages and security update on Auto. I don't want to miss any fixes or new features though. How can I upgrade to a safe version without risking any email, data, or function... as this server is a production server.

    Thanks
     
  2. JustinK

    JustinK Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    251
    Likes Received:
    0
    Trophy Points:
    16
    If you don't want to miss anything, then you can keep up to date by reading through here every few days. Nick's added in update options so that you can set your server to automatically update to a Stable release, a Release release, or a Bleeding Edge release (sounds painful doesn't it?). Stable releases are releases that should be pretty well tested out and debugged. If you're really paranoid like I am though, you'll stick with manual releases and update when you see fit.
     
  3. fog

    fog Well-Known Member

    Joined:
    Jun 22, 2002
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    How do I update manually? What release would you recomend I update to now? Thanks for your reply :)
     
  4. cass

    cass Well-Known Member

    Joined:
    Jul 17, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Argentina/USA/Mexico
    Set WHM to update to RELEASE versions (the default)

    then in SSH run

    /scripts/upcp

    this will manually update WHM & CPANEL to lastest RELEASE build (or edge build in the case you have this selected)

    Regards.
     
  5. fog

    fog Well-Known Member

    Joined:
    Jun 22, 2002
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    I don't have the choice of edge, release, stable or any of that... maybe my version of cpanel/whm is to old as I am using 5.0 build 28?
     
  6. fog

    fog Well-Known Member

    Joined:
    Jun 22, 2002
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    I appreciate the input folks, but I still have some questions (posted above). Could someone help? Thanks
     
  7. bert

    bert Well-Known Member

    Joined:
    Aug 21, 2001
    Messages:
    602
    Likes Received:
    0
    Trophy Points:
    16
    fog,

    If you don't have the option in update preferences is because you are running an older release. I would suggest running /scripts/upcp from your command prompt, this will update your cpanel to the latest &release& release. Once you have that you can go back to WHM and change the update preferences as you wish.
     
  8. fog

    fog Well-Known Member

    Joined:
    Jun 22, 2002
    Messages:
    164
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    Getting ready to do an update.. just want to see if there are any problems with the current release as I'll be upgrading from 5.0 build 28. Please give me some feedback :)
     
Loading...

Share This Page