The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Safest way to upgrade libfontconfig on cpanel

Discussion in 'General Discussion' started by gflamerich, Jan 4, 2012.

  1. gflamerich

    gflamerich Well-Known Member

    Joined:
    Jul 21, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Hi
    We are having an issue with libfontconfig, seems that the version 2.4.1 doesn't support css3 fonts we need for an application.
    I was looking all over the forum and couldn't find anyone upgrading libfontconfig and wonder if anyone has upgraded to 2.4.2 successfully, also, if has instructions to do this on a cpanel box (we found some instructions but none on cpanel). Also if there any action regarding the ignore packages on automatic updates, since yum doesn't show any other version than the one already installed, in order to keep the changes.

    Our cpanel/whm version is:
    WHM 11.30.5 (build 3)
    CENTOS 5.7 x86_64 virtuozzo

    thanks in advance
    Gustavo
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please provide the previously found instructions on how to upgrade so we can know what guide you were reviewing.
     
  3. gflamerich

    gflamerich Well-Known Member

    Joined:
    Jul 21, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Hi cPanelTristan

    What I've found are simple instructions on how to upgrade any package
    Code:
    cd /usr/src
    wget http://fontconfig.org/release/fontconfig-2.4.2.tar.gz
    tar -zxf fontconfig-2.4.2.tar.gz
    cd fontconfig-2.4.2
    ./configure -prefix=/usr
    make
    make install
    Actual distribution of fontconfig is 2.8.0, but 2.4.2 seems to be enough.
    At fontconfig site, the instructions are:
    Code:
    64Bit
    
    Compile the package:
    
    USE_ARCH=64 CC="gcc ${BUILD64}" PKG_CONFIG_PATH="${PKG_CONFIG_PATH64}" \
    ./configure --prefix=/usr \
        --sysconfdir=/etc --localstatedir=/var --disable-docs --without-add-fonts \
        --libdir=/usr/lib64 --with-freetype-config=/usr/bin/freetype-config &&
    make
    
    Install the package
    
    make install &&
    install -v -m644 doc/*.3 /usr/share/man/man3 &&
    install -v -m644 doc/*.5 /usr/share/man/man5 &&
    install -v -m755 -d /usr/share/doc/fontconfig-2.8.0/fontconfig-devel &&
    install -v -m644 doc/*.{html,pdf,txt} /usr/share/doc/fontconfig-2.8.0 &&
    install -v -m644 doc/fontconfig-devel/* /usr/share/doc/fontconfig-2.8.0/fontconfig-devel
    
    The problem is the same with wkhtmltopdf as well, so the upgrade will solve wkhtmltopdf and wkhtmltoimage

    Thanks
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Have you tried these instructions but replacing 2.4.2 in place of 2.8.0 for whenever 2.8.0 is mentioned?
     
  5. gflamerich

    gflamerich Well-Known Member

    Joined:
    Jul 21, 2003
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    Nope, We only have production boxes at this time, so don't have any to test if this doesn't work of makes a mess.
    We usually research at cpanel forum and find someone else that already performed upgrades or installed what we need, but in this case we didn't find any reference.
     
Loading...

Share This Page