Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SCGI - Wrap

Discussion in 'General Discussion' started by Orzammar, Jul 5, 2010.

  1. Orzammar

    Orzammar Registered

    Joined:
    Jul 5, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    51
    Hello!

    I've got a question. I've loaded up an Upload-Script. But when I try to open it as it says in the Panel, there is only shown:

    What to do now?
     
  2. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,157
    Likes Received:
    43
    Trophy Points:
    178
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Did you ever find a solution?

    I am seeing this on one of my server at the moment. Getting the same error. And this is the only thread in the forums that mentions this exact same error.

    Odd.

    - Scott
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Scott,

    Was the script placed into the scgi-bin rather than into the cgi-bin? If so, move it to the cgi-bin and re-attempt running it.

    Otherwise, has SuEXEC been disabled on the machine? You can tell if that's the case in WHM > Apache Configuration > PHP and SuExec Configuration area.

    Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,157
    Likes Received:
    43
    Trophy Points:
    178
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Yes, it had been in the scgi-bin directory for several years. I asked the customer why he had done that, and he could not remember. I then asked him to move it to cgi-bin and try again and it worked.

    Looking in WHM > Apache Configuration > PHP and SuExec Configuration, it shows "Apache suEXEC" as "on".

    At this point, nobody else is complaining (perhaps I do not even have any other customers using scgi wrapper... so I'm going to just shrug my shoulders at this point and move on. :)

    Thanks for looking at this.

    - Scott
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice