The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

scgiwrap: Caller must be uid 99

Discussion in 'General Discussion' started by jenlepp, Jan 22, 2008.

  1. jenlepp

    jenlepp Well-Known Member

    Joined:
    Jul 4, 2005
    Messages:
    116
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Liberty Hill, TX
    cPanel Access Level:
    DataCenter Provider
    I upgraded to Apache 2.2 this past weekend, and everything looked to be going ok until a client emailed in getting this error on their script.

    scgiwrap: Caller must be uid 99

    When I had Apache 1.3, the suexec_log looked like this:

    [2008-01-19 05:13:56]: info: (target/actual) uid: (blah/blah) gid: (blah/blah) cmd: guestbook.cgi
    [2008-01-19 05:13:56]: info: (target/actual) uid: (blah/blah) gid: (blah/blah) cmd: guestbook.cgi
    [2008-01-19 05:13:57]: info: (target/actual) uid: (blah2/blah2) gid: (blah2/blah2) cmd: guestbook.cgi
    [2008-01-19 05:14:32]: info: (target/actual) uid: (blah2/blah2) gid: (blah2/blah2) cmd: agora.cgi

    Now with 2.2 after recompile, they look like this.

    [2008-01-20 14:37:20]: uid: (32307/blahblah) gid: (32309/32309) cmd: Count.cgi
    [2008-01-20 14:37:23]: uid: (32427/blah) gid: (32429/32429) cmd: randomvideo.pl
    [2008-01-20 14:37:23]: uid: (32427/blah) gid: (32429/32429) cmd: currentupdatex.pl
    [2008-01-20 14:37:23]: uid: (32427/blah) gid: (32429/32429) cmd: allusers2.pl

    and they get the errors above. I've recompiled, and still the same thing - is there some step that I missed somewhere that I should have done but didn't do? This is happening on all servers. Also getting an occasional error in the log of:

    [2008-01-20 14:38:43]: cannot stat program: (date --utc)
     
    #1 jenlepp, Jan 22, 2008
    Last edited: Jan 22, 2008
  2. jdlightsey

    jdlightsey Perl Developer III
    Staff Member

    Joined:
    Mar 6, 2007
    Messages:
    126
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston Texas
    cPanel Access Level:
    Root Administrator
    If you update to the latest release of cPanel/WHM, go into the "Configure PHP and Suexec" page on the WHM, change the Suexec setting and save, then change it back and save, does it fix the problem?

    We recently made some changes to the way the suexec binary is managed. If that doesn't sort out your problems I'd be very interested in seeing exactly what is going wrong. Submit a ticket "Attn: JD" if you can.
     
  3. jenlepp

    jenlepp Well-Known Member

    Joined:
    Jul 4, 2005
    Messages:
    116
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Liberty Hill, TX
    cPanel Access Level:
    DataCenter Provider
    I did try turning it off, and then turning it back on again in the way you suggested, but the script still had the error. I wound up just turning it off completely until I could figure out what was going on.

    I get cpanel from my NOC and so they have to submit the ticket - I'll point them to this response and see if we can't figure out what's up.
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    You can still submit a ticket at https://tickets.cpanel.net/submit/ The complimentary queue is pretty small right now so it should get sent to jd quickly (he won't be back till tomorrow morning though most likely)
     
  5. s.a.

    s.a. Active Member
    PartnerNOC

    Joined:
    Aug 16, 2007
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto, Canada
    Here's the reply I got from support regarding this issue:

    "It would appear that scgi has been deprecated in newer cPanel versions. I recommend you move these scripts to the cgi-bin."
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Open a ticket in our complimentary queue, please.
     
  7. s.a.

    s.a. Active Member
    PartnerNOC

    Joined:
    Aug 16, 2007
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto, Canada
    Where's that? I used tickets.cpanel.net
     
  8. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Go to http://tickets.cpanel.net/submit and at the bottom where it says submit a ticket without logging in, follow those instructions :).
     
  9. s.a.

    s.a. Active Member
    PartnerNOC

    Joined:
    Aug 16, 2007
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto, Canada
    Sorry I just don't get it.
    Do you mean I might get a different reply than I got from priority support few hours before?
     
  10. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    What was the ticket ID number?
     
  11. s.a.

    s.a. Active Member
    PartnerNOC

    Joined:
    Aug 16, 2007
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto, Canada
    It's 234128.
     
  12. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Check the ownership/permissions on the scgi wrapper script/binary. The full path is in httpd.conf.
     
  13. jenlepp

    jenlepp Well-Known Member

    Joined:
    Jul 4, 2005
    Messages:
    116
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Liberty Hill, TX
    cPanel Access Level:
    DataCenter Provider
    I have done all that. Also worked on it with my NOC. They caught what we didn't.

    I'm downgrading back to apache 1.3 - I have way too many broken sites, once got hacked today thanks to turning off suexec, and I'm outta patience.

    Thanks.
     
  14. jenlepp

    jenlepp Well-Known Member

    Joined:
    Jul 4, 2005
    Messages:
    116
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Liberty Hill, TX
    cPanel Access Level:
    DataCenter Provider
    Well, I have fixed it - I downgraded, and the correction in the suexec log was immediate. As much as I'd love to help out while it gets looked at, I can't leave a production server with multiple sites broken for days on end - these are hundreds of clients, not my personal fun sites that can sit there broken while everyone says "hmmmm".

    Since it happened on all four servers at the same time when I did the same thing, I'm sure it's not just me, but I think I'll wait for someone else to be the guinea pig before jumping in like that again.
     
  15. dflteche

    dflteche Member

    Joined:
    Dec 30, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Caller must be uid 99

    Hello,


    Add following entry in httpd.conf file on the server :

    AddHandler cgi-script .cgi .pl

    It works for me :)
     
  16. ManojB

    ManojB Well-Known Member

    Joined:
    Mar 25, 2005
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    pune
    Hello

    I have already added "AddHandler cgi-script .cgi .pl" in the httpd.conf but still same problem ...

    Anyone or its a bug ?
     
    #16 ManojB, Feb 23, 2008
    Last edited: Feb 23, 2008
  17. gkgcpanel

    gkgcpanel Well-Known Member

    Joined:
    Jun 6, 2007
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Yes. Happening now with hundreds of sites after recompiling Apache 2.2 using Easy Apache 3

    I have moved one of the sites over to using cgi-bin (instead of scgi-bin) and it started working, but I moved another site and it is not working...

    I have hundreds of sites that are having issues like this. Most have not yet noticed the errors, but when they do, the phone will start ringing...

    Anyone else have a solution? I already tried adding the AddHandler (it was already there).
     
  18. gkgcpanel

    gkgcpanel Well-Known Member

    Joined:
    Jun 6, 2007
    Messages:
    217
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    UPDATE!! I FOUND A SOLUTION THAT SEEMS TO WORK, but it will take a long time.

    I edited httpd.conf and found the site that was having the issue and added another ScriptAlias line below the original...

    ORIGINAL: ScriptAlias /cgi-bin/ /home/XXXXXX/public_html/cgi-bin/
    ADDED: ScriptAlias /scgi-bin/ /home/XXXXXX/public_html/scgi-bin/

    Then restarted httpd and the scripts now work for that user. But it's going to be a pain in the a** to do this for every site...
     
  19. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    Has anyone logged a ticket for this? It must be a bug.

    Whats the point in using scgi anyway ? Cant the customers just use normal cgi ? How did this scgi folder appear in the customers account? Did they create it themselves? Can I disable it and force them to use standard cgi ?
     
  20. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    scgi is a variant of the CGI protocol: http://en.wikipedia.org/wiki/Simple_Common_Gateway_Interface
     
Loading...
Similar Threads - scgiwrap Caller must
  1. lakis
    Replies:
    1
    Views:
    144

Share This Page