The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

scgiwrap: Unable to find the out the username from the home directory

Discussion in 'General Discussion' started by latpanel, May 1, 2004.

  1. latpanel

    latpanel Well-Known Member

    Joined:
    Jan 23, 2004
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    scgiwrap: Caller must be uid 99

    I've enabled the CGI wrapper, but the scripts doesnt run. Teh browser shows the message
    scgiwrap: Caller must be uid 99

    I've enabled suExec

    Thanks
     
    #1 latpanel, May 1, 2004
    Last edited: May 1, 2004
  2. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    If you've enabled your suexec, make sure the "cgi-bin" folder or what ever folder the script(s) reside in, that the folder is chmoded 0755 otherwise you'll get errors. Make sure the script is executable, usually chmoded 0755. Also in the httpd.conf that the User and Group has been added to the account VirtualHost directive.

    IMHO the scgiwrapper used it really useless! :)

    Mickalo
     
  3. dflteche

    dflteche Member

    Joined:
    Dec 30, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Caller must be uid 99

    Hello,

    Add following entry in httpd.conf file on the server :

    AddHandler cgi-script .cgi .pl
     
Loading...

Share This Page