The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Scrambled Groups and Ham! :-}

Discussion in 'General Discussion' started by asuservice, Nov 24, 2001.

  1. asuservice

    asuservice Well-Known Member

    Joined:
    Oct 24, 2001
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Just discovered a weird thing on my box ... FTP started just saying \"Access Denied\" when trying to transfer files so I took a look through shell and found several of the sites had been scrambled in regard to group ownership.

    I\'m not positive as to when it happened but the only thing I can think of that was done between the time all was well and when I found this was I made some changes to the plans. After the changes several sites were updated and I THINK the effected sites were the same ones I later found with screwed up groups.

    It wasn\'t that big of a deal to change it but I thought I\'d post this as an FYI and possibly a bug report. I hope my info is accurate ... I am guessing as to changes made during the time frame that things went wacko.

    Hope everyone had a Good Turkey Day! :D
     
  2. asuservice

    asuservice Well-Known Member

    Joined:
    Oct 24, 2001
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Well, I thought I caused this by changing the plans but it doesn\'t look like it as it has happened two days in a row, and I haven\'t changed a thing.

    I haven\'t established a parttern yet but some of the sites are changed to someone elses group and some are changed to a group of 520 or 521.

    It appears it only effects the group settings ... anyone else getting this? It\'s starting to drive me crazy having to go in and change them every day. :(

    Thanks!

    Mike
     
  3. tabernack

    tabernack Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    This is a bug in cpanel that was reported ages ago. Not sure why it\'s still happening. Maybe Nick hasn\'t figured out the problem yet. I\'ve seen this happen on several cpanel based servers. UID/GID\'s mysteriously change to another user.
     
  4. asuservice

    asuservice Well-Known Member

    Joined:
    Oct 24, 2001
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    Thanks Tabernack,
    I checked it this morning and everything was fine. So it makes me wonder if ...

    #1: It\'s fixed
    #2: it only happens when cpanel does and update and no update loaded last night.

    I\'ll watch it over the next few days and submit a bug report if it continues.

    Thanks Again!

    Mike
     
  5. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    I hav only see this happen (3-4 times) and it always seems to happen when you upgrade/downgrade / delete / move / all that kinda stuff.
     
  6. shannon

    shannon Well-Known Member

    Joined:
    Mar 25, 2002
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Just a note, this is still randomly happening w/ the latest cPanel/WHM... I've seen it twice now on two seperate servers... the userid stays right, but the GUID gets changed to another account. No rhyme or reason as of yet...
     
  7. kosmo

    kosmo Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    403
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    All over Europe
    I noticed this happening when adding a new account. Don't know if it happens when upgrading/downgrading.

    kosmo
     
  8. rupdog

    rupdog Active Member

    Joined:
    May 18, 2002
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Same here

    I am seeing this a lot recently where user changes to some other user. any resolution to this yet ??

    This is important
     
  9. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    [quote:7c77b3c754][i:7c77b3c754]Originally posted by rupdog[/i:7c77b3c754]
    This is important [/quote:7c77b3c754]

    Indeed it is. Possible cause number one when you are running SuExec and someone's cgi scripts suddenly stop working...

    ... or your own scripts stop working (Alas! And it does happen!)
     
Loading...
Similar Threads - Scrambled Groups Ham
  1. studioq
    Replies:
    3
    Views:
    414

Share This Page