The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

screen with CentOS 6 - cPanel breaks it for non-root users?

Discussion in 'General Discussion' started by orudge, Oct 28, 2011.

  1. orudge

    orudge Member

    Joined:
    Oct 31, 2004
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    United Kingdom
    Hello,

    My apologies if this is considered off-topic, but I'd like to enquire if anybody has encountered the following issue. I'm trying to use the GNU `screen' utility on CentOS 6.0 x86_64 as a non-root user. On a clean install of CentOS 6, it works fine. However, once cPanel has been installed, screen refuses to run under non-root users, displaying the following error:

    "No more PTYs. Sorry, could not find a PTY."

    If you check Google, people suggest that it may be a permission issue with /dev/pty*, or /dev/ptmx, or that /dev/ptmx isn't mounted, but that's not the issue here. Permissions all appear to be fine, and the device is mounted.

    I notice that cPanel removes the setgid permission from /usr/bin/screen during installation, but setting the permissions back to 2755 does not make any difference. I also tried removing screen using yum and reinstalling it, but this did not help. I've reproduced this on two different servers, and the results are the same. I've not been able to figure out what else may be going on, but cPanel has done something or installed some package that is causing this problem. Does it in some way manipulate or modify udev?

    On CentOS 5 with cPanel, screen worked fine under any user. screen does work under the root user on CentOS 6 with cPanel, but not for any other user. I have users who depend on having screen access, so it would be nice to get this fixed.

    If anybody has any thoughts or suggestions, I'd really appreciate hearing them. I realise this may not be a 'supported' configuration by the cPanel staff, but it seems strange that cPanel should be able to break a third-party utility in this manner!

    Thanks,
     
Loading...

Share This Page