The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/script/checkperlmodules error, "Cannot resolve protocol tcp"

Discussion in 'General Discussion' started by Sarteck, Nov 8, 2012.

  1. Sarteck

    Sarteck Registered

    Joined:
    Nov 8, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Right, so we were migrating a bunch of VZ containers the other day, and most went off without a hitch. However, a few gave us some trouble.

    Right now, one will not load anything but the default cPanel page, and when trying to go to the cPanel login page, it gives an error:
    "Error code: ssl_error_bad_mac_read".

    I've been trying to track that down, and ended up checking the perl modules, but I get the following:

    Code:
    root@falcon [~]# /scripts/checkperlmodules
    ..Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp....Cannot resolve protocol tcp..httpupdate.cpanel.net did not have any working mirrors.  Please check your internet connection or dns server. at /usr/local/cpanel/Cpanel/HttpRequest.pm line 596.
    DNS seems to be okay--I can ping other servers by name and by IP.

    Anyone got some advice on how to go about debugging this?
     
  2. prajithp13

    prajithp13 Member

    Joined:
    Jun 12, 2012
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    cPanel Access Level:
    Root Administrator
    check your /etc/services file, seems the file is not there or its corrupted
     
Loading...

Share This Page