The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/script/makecpphp problem

Discussion in 'General Discussion' started by csepulveda, Dec 10, 2007.

  1. csepulveda

    csepulveda Member

    Joined:
    Dec 7, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I try to update php version after upgrade mysql version (4.1 -> 5.0) but i have this problem.

    Code:
    /scripts/makecpphp
    Rebuilding cPanel's internal PHP installation...
    (This is *NOT* the PHP installation used with Apache)
    
    Can't locate Cpanel/PHPConfig.pm in @INC (@INC contains: /usr/local/cpanel /var/cpanel/perl/easy /scripts /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /var/cpanel/perl/easy/Cpanel/Easy/Utils/PHP.pm line 15.
    BEGIN failed--compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy/Utils/PHP.pm line 15.
    Compilation failed in require at (eval 64) line 3.
            ...propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
     at (eval 62) line 3
     at /var/cpanel/perl/easy/Cpanel/Easy.pm line 16
    BEGIN failed--compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy.pm line 16.
    Compilation failed in require at (eval 1) line 3.
            ...propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
    BEGIN failed--compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy/Apache.pm line 8.
    Compilation failed in require at /scripts/easyapache line 15.
    
    thanks.
     
  2. cPanelBilly

    cPanelBilly Guest

    running
    /scripts/upcp --force
    should fix it.
     
  3. csepulveda

    csepulveda Member

    Joined:
    Dec 7, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    thanks.

    but now i have the next message

    Code:
    # /scripts/makecpphp
    Rebuilding cPanel's internal PHP installation...
    (This is *NOT* the PHP installation used with Apache)
    
    !! Pre allocation testing was successfully able to allocate 90MB !!
    !!
    Ouput from '/bin/sh -c "ulimit -a"':
    core file size          (blocks, -c) 0
    data seg size           (kbytes, -d) unlimited
    file size               (blocks, -f) unlimited
    pending signals                 (-i) 1024
    max locked memory       (kbytes, -l) 32
    max memory size         (kbytes, -m) unlimited
    open files                      (-n) 1024
    pipe size            (512 bytes, -p) 8
    POSIX message queues     (bytes, -q) 819200
    stack size              (kbytes, -s) 10240
    cpu time               (seconds, -t) unlimited
    max user processes              (-u) 32764
    virtual memory          (kbytes, -v) unlimited
    file locks                      (-x) unlimited
    !!
    !! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1197311804' !!
    !!
    Ouput from '/bin/sh -c "ulimit -a"':
    core file size          (blocks, -c) 524288
    data seg size           (kbytes, -d) unlimited
    file size               (blocks, -f) unlimited
    pending signals                 (-i) 1024
    max locked memory       (kbytes, -l) 32
    max memory size         (kbytes, -m) 524288
    open files                      (-n) 1024
    pipe size            (512 bytes, -p) 8
    POSIX message queues     (bytes, -q) 819200
    stack size              (kbytes, -s) 10240
    cpu time               (seconds, -t) unlimited
    max user processes              (-u) 32764
    virtual memory          (kbytes, -v) 524288
    file locks                      (-x) unlimited
    !!
    !! Skipping backup, --only does not include Apache !!
    Checking that all tarballs are present and up to date.
    Can't locate object method "fix_glibc_dummy" via package "Cpanel::Easy::Apache" at /var/cpanel/perl/easy/Cpanel/Easy.pm line 825.
    phpmyadmin don't waork and y have this message error.

    Code:
    /usr/local/cpanel/3rdparty/bin/php: /usr/lib/mysql/libmysqlclient.so.14: version `libmysqlclient_14' not found (required by /usr/local/cpanel/3rdparty/bin/php)
     
  4. csepulveda

    csepulveda Member

    Joined:
    Dec 7, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    new problem..

    if I try acces to whm from www.domian.com/whm i get this message

    Code:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    
    Please contact the server administrator, webmaster@xxxxxxxx.cl and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    
    More information about this error may be available in the server error log.
    
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.39 Server at www.xxxxxxxxxx.cl Port 80
    but I can access from www.domian.com:2086 and 2087 all waorks fine :confused:
     
  5. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The above was fixed by the latest build of EasyApache 3 (which makecpphp uses). Executing makecpphp again will pull in the fix.

    The other issue is a problem with the Alias used by Apache. It make be the CGI module is not installed/functioning in your Apache build. What does /usr/local/apache/bin/httpd -l output?
     
  6. csepulveda

    csepulveda Member

    Joined:
    Dec 7, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    the problem was solved.

    I upgrade to apache 2.2.

    thanks.
     
Loading...

Share This Page