Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Script not compatible with the selected install location

Discussion in 'EasyApache' started by Leon savvides, Jan 8, 2019.

  1. Leon savvides

    Leon savvides Member

    Joined:
    Sep 2, 2016
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Polis
    cPanel Access Level:
    Root Administrator
    cPanel Version 76.0 (build 15)
    php 5.6

    what to do to bypass these : // made trying install PRESTASHOP... ? see and attachments... needed install anything CLI...? is CLI available from cPanel?

    Version
    Select the version of PrestaShop to install.

    ! The selected version 1.7.5.0 is not compatible with the selected install location.

    Requirements:
    php-allow-url-fopen ON (detected: OFF)
    php-fileinfo 1- (detected: OFF)
    php-soap 1- (detected: OFF)
     

    Attached Files:

  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,009
    Likes Received:
    2,123
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @Leon savvides,

    The "allow_url_fopen" PHP option falls under the "PHP_INI_SYSTEM" category:

    PHP: List of php.ini directives - Manual
    PHP: Where a configuration setting may be set - Manual

    You'd need to enable the option globally via "WHM >> MultiPHP INI Editor". Also, if you are using PHP-FPM, make note of the information in the following resource:

    Tutorial - Managing php.ini directives with PHP-FPM

    Regarding fileinfo and soap, can you verify these PHP extensions were enabled and installed in your EA4 profile via WHM >> EasyApache 4? If so, please post the output from the commands below:

    Code:
    rpm -qa|grep fileinfo
    rpm -qa|grep soap
    If not, you can install them for PHP version 5.6 (the version you noted as using) via WHM >> EasyApache 4 or via the following commands:

    Code:
    yum install ea-php56-php-fileinfo
    yum install ea-php56-php-soap
    
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Leon savvides

    Leon savvides Member

    Joined:
    Sep 2, 2016
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Polis
    cPanel Access Level:
    Root Administrator
    What to do to use PHP 7+ in this version of cPanel... ? I think upper was php 5.6 - can go php 7.x ???
    ?
    How to do the pre-said on php 7.x... ?
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,009
    Likes Received:
    2,123
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @Leon savvides,

    You can enable additional PHP versions when customizing your EA4 profile using WHM >> EasyApache 4. Then, browse to WHM >> MultiPHP Manager to configure the default PHP versions for your domains.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Leon savvides

    Leon savvides Member

    Joined:
    Sep 2, 2016
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Polis
    cPanel Access Level:
    Root Administrator
    Updated to 7.2 but ... but see attachments is ENABLED --- what must do? restart server????

    ! The selected version 1.7.5.0 is not compatible with the selected install location.

    Requirements:
    php-allow-url-fopen ON (detected: OFF)
     

    Attached Files:

  6. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,009
    Likes Received:
    2,123
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Leon savvides

    Leon savvides Member

    Joined:
    Sep 2, 2016
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Polis
    cPanel Access Level:
    Root Administrator
    I went here enable this "allow_url_fopen"
    and installer proceed OK - thank you for your help - keep up good help work!
    whm
    Home »Software »MultiPHP INI Editor
    Documentation
     
    cPanelMichael likes this.
  8. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,009
    Likes Received:
    2,123
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi @Leon savvides,

    I'm glad to see that helped! I've marked this thread as solved.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice