Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

ScriptAlias for cgi-bin has dissapeared in STABLE

Discussion in 'General Discussion' started by sehh, Feb 4, 2009.

  1. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    168
    Location:
    Europe
    I have added the "ScriptAlias /cgi-bin/ /home/username/public_html/cgi-bin/" line manually in the httpd.conf for a single domain which needs it, but thats not a real solution...

    Why is it that all my domains have CGI enabled, but none have the ScriptAlias setting?

    Is there a system-wide CGI option that has them all disabled?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    168
    Location:
    Europe
    After upgrading to the latest STABLE, my apache httpd.conf has lost all ScriptAlias cgi-bin definitions!

    I opened WHM, went to Account Functions and Modify Account, disabled and re-enabled CGI access and that made no difference, none of my accounts have a ScriptAlias line for cgi-bin.

    Please help.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice