Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

/scripts/admin not working

Discussion in 'General Discussion' started by Tagor, Nov 28, 2004.

  1. Tagor

    Tagor Well-Known Member

    Joined:
    Mar 6, 2004
    Messages:
    193
    Likes Received:
    0
    Trophy Points:
    166
    Can't load '/usr/local/cpanel/perl/auto/Newt/Newt.so' for module Newt: libslang.so.1: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 229.
    at /usr/local/cpanel/whostmgr/bin/whostmgrlite line 20
    Compilation failed in require at /usr/local/cpanel/whostmgr/bin/whostmgrlite line 20.
    BEGIN failed--compilation aborted at /usr/local/cpanel/whostmgr/bin/whostmgrlite line 20.


    Does anyone know how to fix this?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    I get the same on correctly configured servers. Is that scripted even used anymore? What are you trying to achieve by running it?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Tagor

    Tagor Well-Known Member

    Joined:
    Mar 6, 2004
    Messages:
    193
    Likes Received:
    0
    Trophy Points:
    166
    It is a lite version of WHM, which can be used in shell.

    I have read more topics about this error. But nobody has a solution.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    It's possible they're no longer supporting it. Have you checked and/or logged the problem in bugzilla?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Tagor

    Tagor Well-Known Member

    Joined:
    Mar 6, 2004
    Messages:
    193
    Likes Received:
    0
    Trophy Points:
    166
    I guess they would already have removed the script in that case...
     
  6. alwaysweb

    alwaysweb Well-Known Member

    Joined:
    Mar 8, 2002
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    306
    Location:
    Dallas, TX
    cPanel Access Level:
    Root Administrator
    The script is still included/supported in cpanel... To fix the error run this via SSH as root:

    Code:
    cd /usr/lib
    ln -s libslang.so libslang.so.1
    Fixed it for us! ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. __arjun__

    __arjun__ Guest

    That didnt work for me :(
    Can you provide the follwoing details:

    slang devel version
    popt library version

    I'm running slang-1.4.5-16, popt-1.8-0.69 and the librarys are correctly linked.
    I'm getting segmentation faults.

    Code:
    /scripts/admin: line 6: 23295 Segmentation fault      (core dumped) perl /usr/local/cpanel/whostmgr/bin/whostmgrlite
    
    line 6 is nothing but perl /usr/local/cpanel/whostmgr/bin/whostmgrlite

    Any Idea??
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice