Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

/scripts/cpbackup typo or bug (needs attention) [10.8.1-C41]

Discussion in 'Data Protection' started by Danny_T, Dec 8, 2005.

  1. Danny_T

    Danny_T Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    181
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Netherlands
    Last week i get this in the conjob report of cpbackup:

    Try `tar --help' for more information.
    tar: You must specify one of the `-Acdtrux' options
    Try `tar --help' for more information.
    pkgacct started.
    pkgacct version 4.1 - running with uid 0
    using time::hires for speedups
    Copying Reseller Config...Done


    In this script i see :
    #!/usr/bin/perl
    # cpanel10 - cpbackup Copyright(c) 1997-2005 cPanel, Inc.
    # All rights Reserved.
    [lot lines down]

    cpusystem('tar',"--exclude='*/proc'",'cfzp',"$target/dirs/$rawdir.tar.gz",$dir);

    Thats wrong

    Must be :

    cpusystem('tar','cfzp',"$target/dirs/$rawdir.tar.gz",$dir,"--exclude='*/proc'");

    Then it works again but! after daily /scripts/upcp running job :

    Updating /scripts ...
    Sync Source: http://httpupdate.cpanel.net/CURRENT/scripts
    Fetching http://httpupdate.cpanel.net/cpanelsync/CURRENT/scripts/.cpanelsync.lock (0)....@69.90.250.34......connected......receiving...100%......Done
    Fetching http://httpupdate.cpanel.net/cpanelsync/CURRENT/scripts/.cpanelsync.bz2 (0)....@69.90.250.34......connected......receiving...33%...66%...99%...100%......Done
    Fetching http://httpupdate.cpanel.net/cpanelsync/CURRENT/scripts/cpbackup.bz2 (0)....@69.90.250.34......connected......receiving...100%......Done
    Got file ./cpbackup ok (md5 matches)
    Done updating /scripts

    The modified line is changed back by this update.

    PLease change the line so i dont have to change it back and run ./cpbackup --forced manual daily :)

    System/version info:

    WHM 10.8.0 cPanel 10.8.1-C41
    Fedora i686 - WHM X v3.1.0

    Thanks.

    Danny_T
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    If you had searched the forums for that error you would have seen that it's already been reported and is fixed in the latest EDGE release (see the change log).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Danny_T

    Danny_T Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    181
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Netherlands
    Not all people running EDGE, so update CURRENT too then ppl are happy too, at the time i did look at the Changelog link in whm it was not noted yet (now it is)

    And i thought i was first one that had this problem because i did find any posts about this at the time i found it. So i thought its been a few days so lets post my findings.

    So, update CURRENT too :) until then i am unhappy.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice