/scripts/dnscluster synczone - 401 access denied

MediaServe

Well-Known Member
PartnerNOC
Apr 9, 2004
138
2
168
Dallas, Texas
cPanel Access Level
DataCenter Provider
Starting yesterday, 04/16/2008, current build updated automatically, /scripts/dnscluster synczone [zone] no longer works, producing errors like this:

(internal error) Unable to add the zone somedomain.com on the remote server [x.x.x.x] (HTTP/1.1 401 Access Denied)

I checked the cluster configuration of each member of the cluster, no problems noted.

I completely dropped all cluster configurations and recreated them from scratch, no help.

Can anyone else who is running current with automatic updates run /scripts/dnscluster synczone on a domain in their cluster and see if this is a problem for more than just me?

I have two separate hosting brands, with separate equipment, and clusters for both of them are behaving the same way, so I don't think this is a localized problem.
 

Chocobo22687

Member
Oct 23, 2006
15
0
151
I'm not getting errors, but when I have just noticed that when creating a zone its not being added to the clustered DNS servers.

Adding/readding the DNS Cluster produced no resolution, manual sync of all domains only affectes / reloads on the local machine.

Certainly appears to be an issue here.
 

MediaServe

Well-Known Member
PartnerNOC
Apr 9, 2004
138
2
168
Dallas, Texas
cPanel Access Level
DataCenter Provider
Same here. I guess I'll see if anyone else, or cpanel, weighs in before rolling back to Release. I have 10 servers in the larger cluster that I'll have to rollback, not something I feel like doing unless I'm sure it's absolutely necessary. I only have 2 in my other cluster - maybe I'll try rolling them back and see what happens.
 

Chocobo22687

Member
Oct 23, 2006
15
0
151
Current 23522
2008-04-18 11:26:14

Fixes
Added check for non executable traceroute when using the old API
Fixed erroneous detection of 'vserver' environment
Resolved issue with DNS Cluster sync failing '401 Access Denied' error
Resolved regression with Account Creation ignoring plan specification
 

MediaServe

Well-Known Member
PartnerNOC
Apr 9, 2004
138
2
168
Dallas, Texas
cPanel Access Level
DataCenter Provider
Just curious - is anyone else noticing this problem with Current? We rolled back to Release, then found a Horde redirect loop on every server and fixed it by rolling back to Stable. I'd really rather be on Current, but not if this DNS clustering problem is still present.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
458
cPanel Access Level
Root Administrator
Just curious - is anyone else noticing this problem with Current? We rolled back to Release, then found a Horde redirect loop on every server and fixed it by rolling back to Stable. I'd really rather be on Current, but not if this DNS clustering problem is still present.
The issue was resolved the same day it was brought to our attention. Builds 23522 and higher have resolved the issue.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
458
cPanel Access Level
Root Administrator
Thanks Kenneth. I don't know why I didn't read the last posts before I responded, shoulda seen the answer from Chocobo22687 before I posted.
The morning coffee probably had not percolated through enough brain cells to register all the posts. :D
 

ebatista

Member
Jan 23, 2006
6
0
151
I still having problems with dns cluster. Since the last upgrade it does not work anymore.

I use cPanel Stable and my whm version is WHM 11.15.0 cPanel 11.18.5-S23897 . Bellow there is the error message when i execute the script /scripts/dnscluster :

/scripts/dnscluster synczone xxxxxxxxxx.com
(internal error) Unable to get the zone xxxxxxxxxx.com from the remote server [xx.xx.xx.xx] (HTTP/1.1 401 Access Denied)
(internal error) Unable to save the zone xxxxxxxxxx.com on the remote server [xx.xx.xx.xx] (HTTP/1.1 401 Access Denied)