The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/scripts/easyapache not working

Discussion in 'EasyApache' started by JoeB, Feb 12, 2006.

  1. JoeB

    JoeB Registered

    Joined:
    Dec 6, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to add curl and upgrade apache to 4.4.1 using both the WHM Apache Update and /scripts/easyapache. Both accept my selections but instead of rebuilding apache it seems like it just restarts apache. I do get some expat error using advanced mode selecting curl/php and also by picking a beginner option. I am not sure where I could check the location of the file it is looking for.

    Code:
    1) Beginner without/phpsuexec + webroot protection support (*** DEFAULT ***)
    2) Beginner with/phpsuexec support + web root protection
    3) Beginner with/php mcrypt support (if php will not compile, you must choose option 1)
    4) Beginner with/php gd+freetype support (if php will not compile, you must choose option 1)
    5) Beginner with/php gd+freetype+mcrypt support (if php will not compile, you must choose option 1)
    6) Advanced (Experts Only, At Your Own Risk)
    7) Advanced [Load Previous Config] (Experts Only, At Your Own Risk)
    8) Failsafe mode (Resets apache config to default, USE ONLY AS A LAST RESORT)
    ---->5
    Apache automatically configured with gd+ttf+mcrypt support!
    Untarring expat...realget: missing URL
    Usage: realget [OPTION]... [URL]...
    
    Try `realget --help' for more options.
    Unable to fetch expat-1.95.6.tar.gz
    Waiting for httpd to restart..............finished.
    
    root      5808  1.3  0.6 12544 6980 ?        S    12:59   0:00 /usr/local/apache/bin/httpd -DSSL
    
    httpd started ok
    The php version does not update and curl support is not added. Any help would be great.

    Thanks
     
  2. 24x7team

    24x7team Well-Known Member

    Joined:
    Jan 16, 2006
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    really tough to find
    If centos try

    yum install -y expat


    else in RHEL try

    up2date expat


    then try with /scripts/easyapache
     
  3. flashweb

    flashweb Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    243
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I am having same error on FreeBSD 5.4

    server have a different version of expat installed

    myserver# pkg_info|grep expat
    expat-1.95.8 XML 1.0 parser written in C
    myserver#

    I can't find the version rquired by cpanel on ports.

    How to fix this ?

    Regards,

    Yujin
     
Loading...

Share This Page