The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/scripts/easyapache problem

Discussion in 'EasyApache' started by smachol, Sep 2, 2004.

  1. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    The last two times I ran /scripts/easyapache to update Apache and PHP, PHP would not update. The pomnly thing I see is this in the printout:

    make php-4.3.8...(clean)....Done
    make php-4.3.8......................................................Done
    make: *** [ext/gd/libgd/gdft.lo] Error 1
    make php-4.3.8...(install)....Done
    make: *** [ext/gd/libgd/gdft.lo] Error 1

    Anyone know what is causing this and how I get it fixed?

    I also tried this via the link in WHM. At first it seemed to go fine. There were no errors regarding PHP and it seemed to compile version 4.3.8. However after restarting Apahce it was still running the old version of PHP.

    I am not running any accelrators and easyapache has always worked before. How do I fix this so I can upgrade to PHP 4.3.8?
     
  2. bigpy2003

    bigpy2003 Well-Known Member

    Joined:
    Feb 22, 2004
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    It looks like it's messing up on the 'GD' library...Maybe you don't have it installed or something?
     
  3. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Thanks but I'm sure that's not it. GD has always been installed on my server and easyapache has always complied it fine. The only changes to my server come from the CPanel builds - and I have these set to only update to the stable tree.

    Any other ideas?
     
  4. cPanelBilly

    cPanelBilly Guest

    Please either post or PM me your IP address and a link back to this thread so I can look at the logs.
     
  5. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    PM sent. Thanks.
     
  6. whmapi.scripts

    whmapi.scripts Well-Known Member

    Joined:
    Sep 1, 2004
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    United Kingdom
    This error is probably related to php 4.3.8 ;)

    I prefer to compile and build php myself and encountered the same error on all of my servers when I attempted to build that version of php. I usually go through the source code of any failed php extensions to find the problem but as GD had not really been altered since 4.3.7 I just deleted gd/ from the ext folder of the php 4.3.8 distro and copied the older gd/ folder across from 4.3.7. A messy patch but I didn't have the time to troubleshoot and as the gd library is now working fine and php compiled successfully I doubt I will either :)

    There maybe something at bugs.php.net regarding this?
     
  7. smachol

    smachol Well-Known Member

    Joined:
    Oct 19, 2001
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Well the latest try with easyapache has disabled my server and all it's services. What a great birthday present this has been. :(
     
Loading...

Share This Page