The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/scripts/easyapache segfaulting

Discussion in 'EasyApache' started by perlchild, May 10, 2003.

  1. perlchild

    perlchild Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    I had the weirdest experience with one of my clients, an attempt to recompile with FD_SETSIZE to 16k turned into a "apache no longer compiles on this machine"
    despite redownloading, and fixing of configs, etc...

    Has anybody encountered this problem before?
    client is using rh 7.3, apache 1.3.27
    with Cpanel 6.4.0-S16
    and gcc 2.96-113
     
  2. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India

    Tow servers of mine logged the same error.
    pico /etc/httpd/conf/httpd.conf move the last
    ulimit -n 16384 to the first and then easyapache. choose option 6 RAISE FILE LIMIT.

    I got the server's up :).


    Hope this helps!!

    Regards,

    PS : type ulimit from ssh and see what number it gives out if its 1024 then option 6 is must and RAISE FILE Limit
     
  3. perlchild

    perlchild Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    thanks for the assist

    I did that, we will see how it goes,
    but what I wish I understood is why php won't compile at all from easyapache...
    After all, that ulimit is for running an apache with higher limits, it doesn't do anything about compilation
     
  4. perlchild

    perlchild Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    Re: thanks for the assist

    To add fuel to my own thread so to speak, it's not just php any and ALL attemps so far to use easyapache generate segfaults.

    This is on a 6.4.2-S6(displayed as R5 in whm output, see other thread about this bug, seen it on 3 servers so far)
    redhat 7.3 box

    My redhat 7.2 don't seem to display this problem(but then I haven't run easyapache on them recently either)

    Which file causes a segfault is not constant, and some compiles will actually have more than one segfault, either using cpp0 or gcc, most often the error message mentions the standard includes, such as /usr/include/sys/time.h
    I ran /script/fixheaders and /scripts/installrpm cpp and /scripts/installrpm gcc just to make sure it wasn't a corrupted file in gcc or cpp
    so far no luck

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page