The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/scripts/fixwebalizer giving me errors

Discussion in 'General Discussion' started by mizzizzippi, Jun 19, 2005.

  1. mizzizzippi

    mizzizzippi Guest

    I have been looking for a fix to this all day but still do not have one. I hope that someone here can help me out.

    Currently using: RedHat Enterprise 3, CPanel 10.2.0-C131

    When I run /scripts/fixwebalizer it gives me the following error message no matter what user I run it for.


    removed `/home/USERNAME/tmp/webalizer/dns_cache.db'
    Log checker loaded ok..
    ==> Loading Config (cpanellogd) .... Done
    Urchin webserver is not running
    Urchin scheduler is not running
    ==> cpaneld(logger) 8.0 Starting (1 processor system).....
    ==> Shared RRDTOOL support enabled
    Processing USERNAME...
    [add dead subdomain] USERNAME
    [add dead subdomain] USERNAME
    [add dead subdomain] USERNAME
    Run Logs USERNAME,5242880000,
    LANGUAGE: english /usr/local/cpanel/lang/.english
    Processing exim stats for USERNAME .......Done
    LANGUAGE: english /usr/local/cpanel/lang/.english
    WEBLANG english
    Archive Status: 0
    About to fork() [ALL DOMAINS: ]
    Webalizer V2.01-10 (Linux 2.4.21-4.0.1.ELsmp) English
    Error: Can't open log file /usr/local/apache/domlogs/
    /usr/local/cpanel/3rdparty/bin/analog: analog version 5.22/Unix
    /usr/local/cpanel/3rdparty/bin/analog: Warning M: Cache file
    /home/USERNAME /tmp/analog/cache doesn't contain last-seven-day statistics; so
    these may be underestimated
    (For help on all errors and warnings, see docs/errors.html)
    /usr/local/cpanel/3rdparty/bin/analog: Warning F: Failed to open logfile
    /usr/local/apache/domlogs/ ignoring it
    /usr/local/cpanel/3rdparty/bin/analog: Warning R: Turning off empty Virtual
    Host Report
    /usr/local/cpanel/3rdparty/bin/analog: Warning R: In Domain Report, turning
    off pie chart of only one wedge
    Update for config "/home/USERNAME /tmp/awstats/"
    With data in log file "/usr/local/apache/domlogs/"...
    Error: Couldn't open server log file "/usr/local/apache/domlogs/" : Permission denied
    Setup ('/home/USERNAME /tmp/awstats/' file, web server or permissions) may be wrong.
    Check config file, permissions and AWStats documentation (in 'docs' directory).


    It looks like it can not open the needed access logs to process them. I have chmod the log files to 755, 744, 655 etc... with no luck.
  2. mizzizzippi

    mizzizzippi Guest

    I was able to find a fix to the problem. I had to chmod 7755 the domlogs folder instead of 755.

Share This Page