The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Scripts not executing

Discussion in 'General Discussion' started by donnie, Jun 8, 2003.

  1. donnie

    donnie Active Member

    Joined:
    May 23, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    uk
    Hello Everybody,
    I'm a newbie to the Linux and I;m facing a problem regarding to the execution of the script.

    My WHM shows :

    You are running an insecure apache setup. You should run /scripts/easyapache and upgrade to a newer version as soon as possible to avoid your system being compromised.


    Ok, I went to the script folder with the root access and try to execute the following script

    easyapache <enter>

    But it says 'Command not Found'. Also at the end of every script file in this folder there is a gray star. What does that mean ?

    Your help will be appreciated.

    Donnie

    cPanel.net Support Ticket Number:
     
  2. tomfra

    tomfra Well-Known Member

    Joined:
    Sep 30, 2002
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    When you are in the /scripts directory you can execute any script using syntax ./scriptname - i.e. in your case type ./easyapache instead of just easyapache.

    Or from any location type /scripts/easyapache and it will do the trick. The star next to any file means that it is executable.

    Tomas

    cPanel.net Support Ticket Number:
     
  3. donnie

    donnie Active Member

    Joined:
    May 23, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    uk
    Thanks a lot tomfra for your nice help.

    Really it works.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page