The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/scripts/phpup to 2.5.6?

Discussion in 'General Discussion' started by Morley, May 20, 2008.

  1. Morley

    Morley Well-Known Member

    Joined:
    Apr 24, 2007
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Will this actually let me upgrade PHP without having to use EA3? :eek:

    Code:
    /scripts/phpup --dryrun
    Updating PHP...
    Updating PHP 5 to 5.2.6 from 5.2.5
    Not actually running anything as per the 'dryrun' flag
     
  2. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    4
    Trophy Points:
    18
    Yes and no. It will only update PHP(s). It does so by using the Cpanel::Easy framework. It will use the last ea3 profile that was successfully built for the PHP options.

    Its basically asking easyapache to only build the latest PHP4 and/or PHP5 (see --help for info_) inline with what you used last time.
     
  3. Morley

    Morley Well-Known Member

    Joined:
    Apr 24, 2007
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Ok so I ran /scripts/phpup and successfully upgraded PHP but, it still uses EA3 to process everything which seems to take just as long as running a full EA3 update. I wanted to avoid this because everytime I use EA3 it changes the doc root for a site I have with both port 80 and 443 that should point to different doc roots. It changed the port 80 doc root to the same port 443 doc root and I had to quickly fix in the /usr/local/apache/conf/userdata/std/2/user. Is that the correct solution?

    I also get this:
    Code:
    root@tm [~]# /usr/local/apache/bin/apachectl --configtest
    [Wed May 21 10:06:27 2008] [warn] NameVirtualHost xx.xx.xxx.244:443 has no VirtualHosts
    [Wed May 21 10:06:27 2008] [warn] NameVirtualHost xx.xx.xxx.246:443 has no VirtualHosts
    [Wed May 21 10:06:27 2008] [warn] NameVirtualHost xx.xx.xxx.242:443 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    Last time I just removed the extra from http.conf.

    How can I fix without editing http.conf which if over written everytime I run EA3?

    Thanks
     
  4. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    4
    Trophy Points:
    18
    Correct, Its basically asking easyapache to only build the latest PHP4 and/or PHP5 inline with what you used last time.

    Its one of 3 possible solutions currently:
    http://www.cpanel.net/support/docs/ea/ea3/customdirectives.html#vhost

    Multiple Listen directives correct? That should be handled but its possible the datastore or template are corrupt or the Listen directive occurs outside of the main section. Feel free to create a ticket so we can investigate the issue.
     
  5. Morley

    Morley Well-Known Member

    Joined:
    Apr 24, 2007
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Thanks, I've submitted the request.
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    # /usr/local/apache/bin/apachectl --configtest

    The above is an invalid way of initiating the configuration test. apachectl doesn't accept command flags in the form --flag

    The proper method when using apachectl is:

    # /usr/local/apache/bin/apachectl configtest

    Any argument/flag that apachectl doesn't understand is passed blindly to httpd.
     
  7. Morley

    Morley Well-Known Member

    Joined:
    Apr 24, 2007
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Yes, my mistake. Thanks.
     
Loading...

Share This Page