garhiyal

Member
PartnerNOC
Nov 10, 2010
8
0
51
Hi,

cPanel updates are failing on a CloudLinux 7 VPS

Specifically /scripts/rpmup fails with

Code:
Error: Package: alt-libheif-1.12.0-1.el7.x86_64 (cloudlinux-x86_64-server-7)
           Requires: libx265.so.79()(64bit)
           Removing: x265-libs-1.9-1.el7.x86_64 (@cloudlinux-imunify360)
               libx265.so.79()(64bit)
           Updated By: x265-libs-2.9-3.el7.x86_64 (rpmfusion-free-updates)
              ~libx265.so.165()(64bit)
Error: Package: libheif-1.3.2-2.el7.x86_64 (@cloudlinux-imunify360)
           Requires: libx265.so.79()(64bit)
           Removing: x265-libs-1.9-1.el7.x86_64 (@cloudlinux-imunify360)
               libx265.so.79()(64bit)
           Updated By: x265-libs-2.9-3.el7.x86_64 (rpmfusion-free-updates)
              ~libx265.so.165()(64bit)
Any solution?

Thanks

Kirti Singh
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
10,360
1,631
363
cPanel Access Level
Root Administrator
Hey there! This would also happen with a "yum update" outside of cPanel, as these packages are related to the operating system itself and not the cPanel software.

It looks like the rpmfusion-free-updates repository is causing a conflict with packages that CloudLinux/Imunify is trying to download. Can you try disabling the rpmfusion repository, and then running these commands:

Code:
yum clean all
yum makecache
yum update
to see if you still have this issue?
 

garhiyal

Member
PartnerNOC
Nov 10, 2010
8
0
51
Hey there! This would also happen with a "yum update" outside of cPanel, as these packages are related to the operating system itself and not the cPanel software.

It looks like the rpmfusion-free-updates repository is causing a conflict with packages that CloudLinux/Imunify is trying to download. Can you try disabling the rpmfusion repository, and then running these commands:

Code:
yum clean all
yum makecache
yum update
to see if you still have this issue?
Hi,

This worked perfectly fine.

Issue is resolved.

Thanks

Kirti Singh