SOLVED /scripts/upcp --force not working properly

julio malca

Member
Jul 6, 2017
5
0
1
peru
cPanel Access Level
Root Administrator
ERROR
Code:
----------------------------------------------------------------------------------
[2017-07-06 09:47:46 -0500] E (XID hu8mqq) The system failed to execute yum with the arguments “-y -c /etc/yum.conf install redhat-rpm-config --disablerepo=epel” because of an error: The “/usr/bin/yum” command (process 1004338) reported error number 1 when it ended. : There are unfinished transactions remaining. You might consider running yum-complete-transaction, or "yum-complete-transaction --cleanup-only" and "yum history redo last", first to finish them. If those don't work you'll have to try removing/installing packages by hand (maybe package-cleanup can help).
[2017-07-06 09:47:46 -0500] Error: Package: redhat-rpm-config-9.1.0-72.el7.cloudlinux.noarch (cloudlinux-x86_64-server-7)
[2017-07-06 09:47:46 -0500]            Requires: perl-srpm-macros
[2017-07-06 09:47:46 -0500]   checkyum version 22.3
[2017-07-06 09:47:48 -0500] E Sysup: Needed system RPMs were not installed: redhat-rpm-config
[2017-07-06 09:47:48 -0500] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
[2017-07-06 09:47:48 -0500]   The Administrator will be notified to review this output when this script completes
=> Log closed Thu Jul  6 09:47:48 2017
[2017-07-06 09:47:48 -0500] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1499352434.log` failed, exited with code 18 (signal = 0)
=> Log closed Thu Jul  6 09:47:49 2017
=> Log closed Thu Jul  6 09:47:49 2017
=> Log closed Thu Jul  6 09:47:49 2017
----------------------------------------------------------------------------------------

im try to install "perl-srpm-macros"

error
++++++++++++++++++++++++++++++++++++++++++++++++++
[email protected] [~]# yum install perl-srpm-macros-1-8.el7.noarch.rpm
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from CLN.
Loading mirror speeds from cached hostfile
 * cloudlinux-base: repo.cloudlinux.com
 * cloudlinux-updates: repo.cloudlinux.com
 * cloudlinux-x86_64-server-7: xmlrpc.cln.cloudlinux.com
 * epel: mirror.nodesdirect.com
No package perl-srpm-macros-1-8.el7.noarch.rpm available.
Error: Nothing to do
++++++++++++++++++++++++++++++++++++++++++++++++++++++
rewards
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
[2017-07-06 09:47:46 -0500] E (XID hu8mqq) The system failed to execute yum with the arguments “-y -c /etc/yum.conf install redhat-rpm-config --disablerepo=epel” because of an error: The “/usr/bin/yum” command (process 1004338) reported error number 1 when it ended. : There are unfinished transactions remaining. You might consider running yum-complete-transaction, or "yum-complete-transaction --cleanup-only" and "yum history redo last", first to finish them. If those don't work you'll have to try removing/installing packages by hand (maybe package-cleanup can help).
Hello,

The cPanel update is failing because your system is unable to install a required RPM via YUM. Try running the following commands and let us know if the issue persists after installing any available updates through YUM:

Code:
yum-complete-transaction
yum clean all
yum update
Thank you.
 

julio malca

Member
Jul 6, 2017
5
0
1
peru
cPanel Access Level
Root Administrator
hello

im try with
+++++++++++++++
yum-complete-transaction
yum clean all
yum update
+++++++++++++++++

them

/scripts/upcp --force

+++++++++++++++++++++
[2017-07-06 12:14:00 -0500] E (XID 6zfgfe) The system failed to execute yum with the arguments “-y -c /etc/yum.conf install redhat-rpm-config --disablerepo=epel” because of an error: The “/usr/bin/yum” command (process 356984) reported error number 1 when it ended. : Error: Package: redhat-rpm-config-9.1.0-72.el7.cloudlinux.noarch (cloudlinux-x86_64-server-7)
[2017-07-06 12:14:00 -0500] Requires: perl-srpm-macros
[2017-07-06 12:14:00 -0500] checkyum version 22.3
[2017-07-06 12:14:02 -0500] E Sysup: Needed system RPMs were not installed: redhat-rpm-config
[2017-07-06 12:14:03 -0500] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
[2017-07-06 12:14:03 -0500] The Administrator will be notified to review this output when this script completes
=> Log closed Thu Jul 6 12:14:03 2017
[2017-07-06 12:14:03 -0500] 17% complete
[2017-07-06 12:14:03 -0500] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1499361218.log --force` failed, exited with code 18 (signal = 0)
=> Log closed Thu Jul 6 12:14:05 2017
=> Log closed Thu Jul 6 12:14:05 2017
=> Log closed Thu Jul 6 12:14:05 2017
+++++++++++++++++++++++++++++++

same error

help :D
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

Try installing the required package through YUM with the following command:

Code:
yum install perl-srpm-macros
Also, please post the output from the following command:

Code:
grep exclude= /etc/yum.conf
Thank you.
 

julio malca

Member
Jul 6, 2017
5
0
1
peru
cPanel Access Level
Root Administrator
hello.
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[email protected] [~]# yum install perl-srpm-macros
Loaded plugins: fastestmirror, rhnplugin
This system is receiving updates from CLN.
DimeNOC | 2.5 kB 00:00:00
base | 3.6 kB 00:00:00
cloudlinux-base | 3.6 kB 00:00:00
cloudlinux-updates | 3.6 kB 00:00:00
epel/x86_64/metalink | 13 kB 00:00:00
extras | 3.4 kB 00:00:00
updates | 3.4 kB 00:00:00
Loading mirror speeds from cached hostfile
* cloudlinux-base: download.cloudlinux.com
* cloudlinux-updates: download.cloudlinux.com
* cloudlinux-x86_64-server-7: xmlrpc.cln.cloudlinux.com
* epel: mirror.nodesdirect.com
No package perl-srpm-macros available.
Error: Nothing to do
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

[email protected] [~]# grep exclude= /etc/yum.conf
exclude=bind-chroot courier* dovecot* exim* facter filesystem httpd* mod_ssl* mydns* mysql* nsd* p0f perl* php* proftpd* puppet pure-ftpd* spamassassin* squirrelmail*

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

help me pls :D
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

You will need to remove the "perl* entry from the "exclude=" line in your /etc/yum.conf file. This will allow YUM to proceed with the installation of the required RPM.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

I'm glad to see the issue is now solved. Thank you for updating us with the outcome.