/scripts/upcp libhal dependency problems

neon-light

Member
Mar 16, 2006
5
0
151
When /scripts/upcp runs I've been getting dependency problems, I've tried updating the yum package information. Its a fedora core 4 install.

A quote from the middle of the upcp log.
---> Package libIDL.i386 0:0.8.5-2 set to be updated
---> Package gamin.i386 0:0.1.1-3.FC4 set to be updated
---> Package esound.i386 1:0.2.36-0.fc4.1 set to be updated
---> Package audiofile.i386 1:0.2.6-2 set to be updated
---> Package shared-mime-info.i386 0:0.16-3 set to be updated
---> Package dbus-glib.i386 0:0.33-3.fc4.1 set to be updated
---> Package gnome-keyring.i386 0:0.4.2-1 set to be updated
---> Package howl-libs.i386 0:0.9.8-3 set to be updated
---> Package gnome-mime-data.i386 0:2.4.2-1 set to be updated
---> Package freeglut.i386 0:2.2.0-16 set to be updated
---> Package pyorbit.i386 0:2.0.1-4 set to be updated
--> Running transaction check
--> Processing Dependency: libasound.so.2(ALSA_0.9) for pacError: Missing Dependency: libhal.so.1 is needed by package gnome-vfs2
Error: Missing Dependency: libhal-storage.so.1 is needed by package gnome-vfs2
kage: esound
--> Processing Dependency: howl = 0.9.8 for package: howl-libs
--> Processing Dependency: libhal-storage.so.1 for package: gnome-vfs2
--> Processing Dependency: libasound.so.2 for package: esound
--> Processing Dependency: libhal.so.1 for package: gnome-vfs2
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4) for package: esound
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package alsa-lib.i386 0:1.0.10-3.FC4 set to be updated
---> Package howl.i386 0:0.9.8-3 set to be updated
--> Running transaction check
--> Processing Dependency: libhal.so.1 for package: gnome-vfs2
--> Processing Dependency: libhal-storage.so.1 for package: gnome-vfs2
--> Finished Dependency Resolution
There isn't a 'hal' package, so I assume it wants the 'hal-gnome' package? I've tried installing hal-gnome.i386 through yum, but it wants hal version 0.5.2-2.fc4.1, hal-gnome 0.5.2-2.fc4.1 is only available in updates-released repository. Not sure how to specify it should install that version, as trying to install from the 'base' repository just results in the dependency that it needs the 0.5.2-2.fc4.1 version.

Error: Missing Dependency: hal = 0.5.2-2.fc4.1 is needed by package hal-gnome
Error: Missing Dependency: libhal-storage.so.1 is needed by package gnome-vfs2
Error: Missing Dependency: libhal.so.1 is needed by package gnome-vfs2


I've searched these forums, no one else seems to have had this problem.

Suggestions Welcome

Thanks,

Neil C