Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

/scripts/updateuserdomains not working

Discussion in 'General Discussion' started by MediaServe, Mar 31, 2008.

  1. MediaServe

    MediaServe Well-Known Member
    PartnerNOC

    Joined:
    Apr 9, 2004
    Messages:
    130
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Nashville, TN USA
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Just thought I'd post this weird problem I'm having, and see if anyone has any ideas.

    I started getting reports that people weren't receiving email on one of our servers. I poked around and found that suddenly, only a few domains are listed in /etc/localdomains, a fraction of what should be there.

    Running /scripts/updateuserdomains does not correct the file.

    The really strange thing is that while testing, I ran /scripts/eximup --force a couple times, and then started running /scripts/updateuserdomains while eximup was running. During the eximup run, which was paused for a long time on the "exim config PASSED!!" line, (that's not exact, but close enough.), as I ran /scripts/updateuserdomains, each time it was putting more and more domains into the file, as though eximup was processing the domains somehow, and then /scripts/updateuserdomains was picking them up.

    However, once eximup completed, running /scripts/updateuserdomains again caused the file to be truncated again to only the same few domains that were present when I found the problem. I can't find any problems in /var/cpanel/users files, and have no idea how to get this fixed.

    Any ideas?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice