ScriptSock /etc/apache2/run/cgid_sock does not exist:

nisamudeen97

Well-Known Member
Jul 7, 2010
59
5
58
Cochin
cPanel Access Level
Root Administrator
All of a sudden all websites in the server has stopped working and it started showing 503 error. While checking at apache logs I can see the below error.

[cgid:error] [pid 3859:tid 139722986870528] (2)No such file or directory: [client 31.210.20.125:50060] AH02833: ScriptSock /etc/apache2/run/cgid_sock.3850 does not exist: /usr/local/cpanel/cgi-sys/ea-php74

When an apache restart was done, error stopped and websites started working for few minutes. Again the error came back. Can some one help me to find the root cause of the issue?
 

Spirogg

Well-Known Member
Feb 21, 2018
700
161
43
chicago
cPanel Access Level
Root Administrator
All of a sudden all websites in the server has stopped working and it started showing 503 error. While checking at apache logs I can see the below error.

[cgid:error] [pid 3859:tid 139722986870528] (2)No such file or directory: [client 31.210.20.125:50060] AH02833: ScriptSock /etc/apache2/run/cgid_sock.3850 does not exist: /usr/local/cpanel/cgi-sys/ea-php74

When an apache restart was done, error stopped and websites started working for few minutes. Again the error came back. Can some one help me to find the root cause of the issue?
can you give some more info
what OS
what version of cPanel
 

Spirogg

Well-Known Member
Feb 21, 2018
700
161
43
chicago
cPanel Access Level
Root Administrator
All of a sudden all websites in the server has stopped working and it started showing 503 error. While checking at apache logs I can see the below error.

[cgid:error] [pid 3859:tid 139722986870528] (2)No such file or directory: [client 31.210.20.125:50060] AH02833: ScriptSock /etc/apache2/run/cgid_sock.3850 does not exist: /usr/local/cpanel/cgi-sys/ea-php74

When an apache restart was done, error stopped and websites started working for few minutes. Again the error came back. Can some one help me to find the root cause of the issue?
/scripts/rebuildhttpdconf && /scripts/restartsrv_apache


might be same as this issue here
 

Spirogg

Well-Known Member
Feb 21, 2018
700
161
43
chicago
cPanel Access Level
Root Administrator
hen an apache restart was done, error stopped and websites started working for few minutes. Again the error came back
can you give output of apachectl status

also have you tried a hard reset of apache from CLI type :
/scripts/restartsrv_httpd --restart --hard

i
 

cPanelWilliam

Administrator
Staff member
Mar 13, 2018
159
21
93
Houston
cPanel Access Level
Root Administrator
Hello!

Again the error came back. Can some one help me to find the root cause of the issue?

It would be difficult to identify the root cause of the error based on the error log alone in this scenario. @Spirogg asked some great questions, it would be helpful to know what OS you are using and cPanel version, as this issue could be caused by something such as CloudLinux LVE limits, or even PHP-FPM failures.

I would recommend opening a support ticket in this situation so our support team can access your server and help to identify the reason for this error.
 

smoretti

Registered
Aug 4, 2022
1
0
1
Lausanne, Switzerland
cPanel Access Level
Root Administrator
I have the same issue on Rocky Linux release 8.6 (kernel 4.18.0-372.16.1.el8_6.0.1.x86_64) with Apache 2.4.37.

Others guys have the same issue:
- Error accessing cgi script inside Docker container, Operation not permitted: Couldn't bind unix domain socket
- Get error 503 when show probe status (Only when container restart) · Issue #8 · deweysasser/docker-xymon
But specifying a "valid scriptsock" does not work in my hand.

In my case it happens when the apache server runs for several days. It looks to be linked to the log rotation.